Package list ruby-omniauth-twitter / 1ed5f66
Merge pull request #114 from unasuke/drop_eol_ruby Drop support of eol ruby and rubinius Rashmi Yadav authored 4 years ago GitHub committed 4 years ago
4 changed file(s) with 26 addition(s) and 9 deletion(s). Raw diff Collapse all Expand all
0 dist: trusty
1
02 rvm:
1 - 1.9.3
2 - 2.0.0
3 - 2.1
4 - 2.2
5 - jruby
6 - rbx-2
3 - 2.1.10
4 - 2.2.6
5 - 2.3.3
6 - 2.4.0
7 - jruby-1.7.26
8 - rbx-3
9
10 matrix:
11 allow_failures:
12 - rvm: rbx-3
44 gem 'rake'
55
66 group :test do
7 if Gem::Version.create(RUBY_VERSION) < Gem::Version.create("2.0.0")
8 # for jruby 1.7.x
9 gem "addressable", "2.4.0"
10 end
11
12 if Gem::Version.create(RUBY_VERSION) < Gem::Version.create("2.2.2")
13 gem "rack", "~> 1.6"
14 end
15
716 gem 'rspec', '~> 3.2'
817 gem 'rack-test'
918 gem 'simplecov'
155155
156156 ## Supported Rubies
157157
158 OmniAuth Twitter is tested under 1.9.3, 2.0.0, 2.1.x, 2.2.x, JRuby, and Rubinius.
158 OmniAuth Twitter is tested under 2.1.x, 2.2.x and JRuby.
159
160 If you use its gem on ruby 1.9.x, 2.0.x, or Rubinius use version v1.2.1 .
159161
160162 ## Contributing
161163
1515 s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
1616 s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
1717 s.require_paths = ["lib"]
18
19 s.add_dependency 'json', '~> 1.3'
18 s.required_ruby_version = Gem::Requirement.new('>= 1.9.3')
2019 s.add_dependency 'omniauth-oauth', '~> 1.1'
20 s.add_dependency 'rack'
2121 s.add_development_dependency 'bundler', '~> 1.0'
2222 end