Codebase list rust-libslirp / 42c05a2 src / libgit2-sys / debian / patches / no-special-snowflake-env.patch
42c05a2

Tree @42c05a2 (Download .tar.gz)

no-special-snowflake-env.patch @42c05a2raw · history · blame

--- a/build.rs
+++ b/build.rs
@@ -11,7 +11,7 @@
     // To use zlib-ng in zlib-compat mode, we have to build libgit2 ourselves.
     if !zlib_ng_compat {
         let mut cfg = pkg_config::Config::new();
-        if let Ok(lib) = cfg.atleast_version("1.0.0").probe("libgit2") {
+        if let Ok(lib) = cfg.probe("libgit2") {
             for include in &lib.include_paths {
                 println!("cargo:root={}", include.display());
             }
@@ -19,7 +19,7 @@
         }
     }
 
-    if !Path::new("libgit2/.git").exists() {
+    if false {
         let _ = Command::new("git")
             .args(&["submodule", "update", "--init", "libgit2"])
             .status();