update parking-lot-core 0.4 for smallvec 1, to help testing migration
Ximin Luo
3 years ago
77 | 77 |
if ! printf "%s\n" "$versions" | grep "$ARCHIVT" | grep -qF "$rdep"; then
|
78 | 78 |
# we're only interested in packages in both archives.
|
79 | 79 |
# if a pkg-ver is not in either archive, this doesn't affect the migration process
|
|
80 |
#
|
|
81 |
# FIXME: actually, this is not true in the case where we are upgrading
|
|
82 |
# X from version A to B in unstable, but we want to keep X-A in testing.
|
|
83 |
# In this case, X-A has to go through unstable first and we are interested
|
|
84 |
# in keeping this installable, so can't continue here...
|
80 | 85 |
continue
|
81 | 86 |
fi
|
82 | 87 |
apt-cache show "${rdep}=${ver}" \
|
|
0 |
rust-parking-lot-core-0.4 (0.4.0-3) UNRELEASED-FIXME-AUTOGENERATED-DEBCARGO; urgency=medium
|
|
1 |
|
|
2 |
* Team upload.
|
|
3 |
* Package parking_lot_core 0.4.0 from crates.io using debcargo 2.4.2
|
|
4 |
|
|
5 |
-- Ximin Luo <infinity0@debian.org> Fri, 10 Jan 2020 11:39:35 +0000
|
|
6 |
|
0 | 7 |
rust-parking-lot-core-0.4 (0.4.0-2) unstable; urgency=medium
|
1 | 8 |
|
2 | 9 |
* Update rand dependency to 0.7
|
97 | 97 |
|
98 | 98 |
Files: debian/*
|
99 | 99 |
Copyright:
|
100 | |
2019 Debian Rust Maintainers <pkg-rust-maintainers@alioth-lists.debian.net>
|
101 | |
2019 Sylvestre Ledru <sylvestre@debian.org>
|
102 | |
2019 Wolfgang Silbermayr <wolfgang@silbermayr.at>
|
103 | |
2019 kpcyrd <git@rxv.cc>
|
|
100 |
2019-2020 Debian Rust Maintainers <pkg-rust-maintainers@alioth-lists.debian.net>
|
|
101 |
2019-2020 Sylvestre Ledru <sylvestre@debian.org>
|
|
102 |
2019-2020 Wolfgang Silbermayr <wolfgang@silbermayr.at>
|
|
103 |
2019-2020 kpcyrd <git@rxv.cc>
|
104 | 104 |
License: Apache-2.0 or MIT
|
105 | 105 |
|
106 | 106 |
License: Apache-2.0
|
0 | |
diff --git a/core/src/parking_lot.rs b/core/src/parking_lot.rs
|
1 | |
index 64acaf9..b56deef 100644
|
2 | 0 |
--- a/src/parking_lot.rs
|
3 | 1 |
+++ b/src/parking_lot.rs
|
4 | 2 |
@@ -6,7 +6,7 @@
|
0 | 0 |
--- a/Cargo.toml
|
1 | 1 |
+++ b/Cargo.toml
|
2 | |
@@ -28,7 +28,8 @@
|
3 | |
optional = true
|
4 | |
|
5 | |
[dependencies.rand]
|
6 | |
-version = "0.6"
|
7 | |
+version = "0.7"
|
8 | |
+features = ["small_rng"]
|
|
2 |
@@ -32,7 +32,7 @@
|
|
3 |
features = ["small_rng"]
|
9 | 4 |
|
10 | 5 |
[dependencies.smallvec]
|
11 | |
version = "0.6"
|
|
6 |
-version = "0.6"
|
|
7 |
+version = ">= 0.6, < 2"
|
|
8 |
|
|
9 |
[dependencies.thread-id]
|
|
10 |
version = "3.2.0"
|
|
0 |
update-deps.patch
|
0 | 1 |
relax-deps.patch
|
1 | 2 |
rand-0.7.patch
|
|
0 |
--- a/Cargo.toml
|
|
1 |
+++ b/Cargo.toml
|
|
2 |
@@ -28,7 +28,8 @@
|
|
3 |
optional = true
|
|
4 |
|
|
5 |
[dependencies.rand]
|
|
6 |
-version = "0.6"
|
|
7 |
+version = "0.7"
|
|
8 |
+features = ["small_rng"]
|
|
9 |
|
|
10 |
[dependencies.smallvec]
|
|
11 |
version = "0.6"
|