Package list rust-libslirp / 2e8d0d9
nettle-sys: upload 2.0.5 - drop patch already merged upstream - work around #984627 Daniel Kahn Gillmor 8 months ago
7 changed file(s) with 58 addition(s) and 49 deletion(s). Raw diff Collapse all Expand all
0 rust-nettle-sys (2.0.5-1) UNRELEASED-FIXME-AUTOGENERATED-DEBCARGO; urgency=medium
1
2 * Package nettle-sys 2.0.5 from crates.io using debcargo 2.4.4
3 * drop patches already upstream
4 * work around #984627
5
6 -- Daniel Kahn Gillmor <dkg@fifthhorseman.net> Fri, 05 Mar 2021 18:43:51 -0500
7
08 rust-nettle-sys (2.0.4-5) unstable; urgency=medium
19
210 * Package nettle-sys 2.0.4 from crates.io using debcargo 2.4.3
99 Files: *
1010 Copyright:
1111 2017-2019 juga <juga@sequoia-pgp.org>
12 2017-2019 Justus Winter <justus@sequoia-pgp.org>
12 2017-2021 Justus Winter <justus@sequoia-pgp.org>
1313 2017-2019 Kai Michaelis <kai@sequoia-pgp.org>
1414 2017-2019 Neal H. Walfield <neal@sequoia-pgp.org>
1515 License: LGPL-3.0 or GPL-2.0 or GPL-3.0
1616
1717 Files: debian/*
1818 Copyright:
19 2019-2020 Debian Rust Maintainers <pkg-rust-maintainers@alioth-lists.debian.net>
20 2019-2020 Daniel Kahn Gillmor <dkg@fifthhorseman.net>
19 2019-2021 Debian Rust Maintainers <pkg-rust-maintainers@alioth-lists.debian.net>
20 2019-2021 Daniel Kahn Gillmor <dkg@fifthhorseman.net>
2121 2019 kpcyrd <git@rxv.cc>
2222 License: LGPL-3.0 or GPL-2.0 or GPL-3.0
2323
3838
3939 Files: debian/*
4040 Copyright:
41 2019-2020 Debian Rust Maintainers <pkg-rust-maintainers@alioth-lists.debian.net>
42 2019-2020 Daniel Kahn Gillmor <dkg@fifthhorseman.net>
43 2019-2020 kpcyrd <git@rxv.cc>
41 2019-2021 Debian Rust Maintainers <pkg-rust-maintainers@alioth-lists.debian.net>
42 2019-2021 Daniel Kahn Gillmor <dkg@fifthhorseman.net>
43 2019-2021 kpcyrd <git@rxv.cc>
4444 License: LGPL-3.0 or GPL-2.0 or GPL-3.0
4545
4646 License: GPL-2.0
+0
-23
src/nettle-sys/debian/patches/bump-bindgen.patch less more
0 --- a/Cargo.toml
1 +++ b/Cargo.toml
2 @@ -26,7 +26,7 @@
3
4 [dependencies]
5 [build-dependencies.bindgen]
6 -version = "0.51.1"
7 +version = ">= 0.53.1, < 0.56"
8 default-features = false
9
10 [build-dependencies.pkg-config]
11 --- a/build.rs
12 +++ b/new.build.rs
13 @@ -64,7 +64,8 @@
14 // Includes all nettle headers except mini-gmp.h
15 .header("bindgen-wrapper.h")
16 // Workaround for https://github.com/rust-lang-nursery/rust-bindgen/issues/550
17 - .blacklist_type("max_align_t");
18 + .blacklist_type("max_align_t")
19 + .size_t_is_usize(true);
20
21 for p in nettle.include_paths {
22 builder = builder.clang_arg(format!("-I{}", p.display()));
0 --- a/Cargo.toml 2019-10-23 13:08:07.000000000 -0400
1 +++ b/Cargo.toml 2019-10-23 14:08:46.644064014 -0400
2 @@ -29,12 +29,9 @@
3 version = "0.51.1"
0 --- a/Cargo.toml
1 +++ b/Cargo.toml
2 @@ -30,14 +30,11 @@
3 version = ">= 0.53.1, < 0.56"
44 default-features = false
55
66 -[build-dependencies.nettle-src]
1313 [features]
1414 vendored = ["nettle-src"]
1515 +nettle-src = []
16 diff --git a/build.rs b/build.rs
17 index 44f7af3..ede4b2f 100644
16 [target."cfg(target_env = \"msvc\")".build-dependencies.vcpkg]
17 version = "0.2.9"
1818 --- a/build.rs
1919 +++ b/build.rs
20 @@ -1,7 +1,5 @@
21 extern crate bindgen;
22 extern crate pkg_config;
23 -#[cfg(feature = "vendored")]
24 -extern crate nettle_src;
25
26 use std::env;
27 use std::fs;
28 @@ -36,14 +34,6 @@ fn main() {
20 @@ -62,13 +62,6 @@
2921 println!("cargo:rerun-if-env-changed=NETTLE_STATIC");
3022 println!("cargo:rerun-if-env-changed={}", NETTLE_PREGENERATED_BINDINGS);
3123
3325 - {
3426 - let artifacts = nettle_src::Build::new().build();
3527 - println!("cargo:vendored=1");
36 - env::set_var("PKG_CONFIG_PATH",
37 - artifacts.lib_dir().join("pkgconfig"));
28 - env::set_var("PKG_CONFIG_PATH", artifacts.lib_dir().join("pkgconfig"));
3829 - }
3930 -
40 let nettle = pkg_config::probe_library("nettle hogweed").unwrap();
31 let include_paths = try_vcpkg().or_else(try_pkg_config).unwrap();
4132
42 let mode = match env::var_os("NETTLE_STATIC") {
33 let out_path = Path::new(&env::var("OUT_DIR").unwrap()).join("bindings.rs");
0 --- a/Cargo.toml
1 +++ b/Cargo.toml
2 @@ -36,5 +36,3 @@
3 [features]
4 vendored = ["nettle-src"]
5 nettle-src = []
6 -[target."cfg(target_env = \"msvc\")".build-dependencies.vcpkg]
7 -version = "0.2.9"
8 --- a/build.rs
9 +++ b/build.rs
10 @@ -3,22 +3,6 @@
11 use std::path::{Path, PathBuf};
12
13
14 -#[cfg(all(target_env = "msvc", not(feature = "vendored")))]
15 -fn try_vcpkg() -> Option<Vec<PathBuf>> {
16 - let lib = vcpkg::Config::new()
17 - .emit_includes(true)
18 - .find_package("nettle");
19 -
20 - match lib {
21 - Ok(lib) => Some(lib.include_paths),
22 - Err(e) => {
23 - println!("note: vcpkg did not find openssl: {}", e);
24 - None
25 - }
26 - }
27 -}
28 -
29 -#[cfg(any(not(target_env = "msvc"), feature = "vendored"))]
30 fn try_vcpkg() -> Option<Vec<PathBuf>> { None }
31
32 fn print_library(lib: &pkg_config::Library, mode: &str) {
00 disable-vendor.diff
1 bump-bindgen.patch
1 drop-vcpkg.diff