Codebase list splix / 1cd4015d-4c33-46f3-87f0-82c0d142f7db/main debian / patches / 0001-Fix-alignment-problem-on-armel.patch
1cd4015d-4c33-46f3-87f0-82c0d142f7db/main

Tree @1cd4015d-4c33-46f3-87f0-82c0d142f7db/main (Download .tar.gz)

0001-Fix-alignment-problem-on-armel.patch @1cd4015d-4c33-46f3-87f0-82c0d142f7db/mainraw · history · blame

From fe098f575428cc5af59d43db10842735775f7094 Mon Sep 17 00:00:00 2001
From: Luca Niccoli <lultimouomo@gmail.com>
Date: Sun, 12 Jun 2011 15:30:15 +0200
Subject: Fix alignment problem on armel

---
 src/qpdl.cpp | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/src/qpdl.cpp b/src/qpdl.cpp
index 994e1c8..a95f361 100644
--- a/src/qpdl.cpp
+++ b/src/qpdl.cpp
@@ -132,7 +132,7 @@ static bool _renderBand(const Request& request, const Band* band, bool mono)
 {
     unsigned long version, subVersion, size, dataSize, checkSum;
     bool color, headerSent=false;
-    unsigned char header[0x20];
+    unsigned char header[0x20] __attribute__((aligned(4)));
     const BandPlane *plane;
 
     version = request.printer()->qpdlVersion();