Codebase list splix / debian/2.0.0+svn315-6 debian / patches / 0002-Dont-let-bash-trim-whitespace.patch
debian/2.0.0+svn315-6

Tree @debian/2.0.0+svn315-6 (Download .tar.gz)

0002-Dont-let-bash-trim-whitespace.patch @debian/2.0.0+svn315-6raw · history · blame

Description: Set IFS when looping over the file to avoid letting /bin/bash trim the whitespace
 as this makes the build unreproducible.
 The whitespace in the original .drv.in files should be fixed nevertheless.
Author: Didier Raboud
Last-Update: 2016-06-12

--- a/ppd/compile.sh
+++ b/ppd/compile.sh
@@ -14,7 +14,7 @@
 # Function parseFile
 #
 parseFile() {
-    while read LINE; do
+    while IFS= read LINE; do
         if [ -n "`echo "$LINE" | grep '^[ \t]*#import[ \t]*"[a-zA-Z0-9\.\-]*"'`" ]; then
             FILE=`echo "$LINE" | sed -re 's/[ \t]*#import[ \t]"([a-zA-Z0-9\.\-]*)"/\1/'`
             parseFile $FILE $2