Codebase list sugar-etoys-activity / 68cea2d debian / rules
68cea2d

Tree @68cea2d (Download .tar.gz)

rules @68cea2draw · history · blame

#!/usr/bin/make -f
# -*- mode: makefile; coding: utf-8 -*-
# Copyright 2008, 2009, 2010, 2012 Jonas Smedegaard <dr@jones.dk>
# Copyright 2010 Ankur khurana <ankur@seeta.in>
# Description: Main Debian packaging script for Etoys
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation; either version 2, or (at your option)
# any later version.
#
# This program is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
# General Public License for more details.
#
# You should have received a copy of the GNU General Public License
# along with this program.  If not, see <http://www.gnu.org/licenses/>.

#DEB_SUGAR_BRANCHES = 0.86 0.88
DEB_PYTHON_SUGAR_PACKAGES = sugar-etoys-activity
include /usr/share/cdbs/1/rules/upstream-tarball.mk
include /usr/share/cdbs/1/rules/utils.mk
include /usr/share/cdbs/1/class/python-sugar.mk
include /usr/share/cdbs/1/rules/debhelper.mk

pkg = $(DEB_SOURCE_PACKAGE)
DEB_SUGAR_PRIMARY_BRANCH = 0.88

DEB_UPSTREAM_PACKAGE = Etoys
DEB_UPSTREAM_URL = http://download.sugarlabs.org/sources/sucrose/fructose/$(DEB_UPSTREAM_PACKAGE)
DEB_UPSTREAM_TARBALL_MD5 = 44673a6624aa695e661b799d2a92b522

DEB_SUGAR_PRIMARY_BRANCH = 0.88

CDBS_DEPENDS_$(pkg) = $(call cdbs_sugar_anybranchdeps,python-sugar python-sugar-toolkit)
CDBS_DEPENDS_$(pkg) += , python-hippocanvas, python-telepathy, python-gtk2, python-cjson
CDBS_DEPENDS_$(pkg) += , sugar-presence-service-0.90 | sugar-presence-service

# Suppress unneeded auto-resolved build-dependency on python-dev
CDBS_BUILD_DEPENDS_class_python-sugar_python = python$(cdbs_python_nondefault_version)

clean::
	find -name *.mo -delete
	find -name *.linfo -delete