Codebase list sugar-log-activity / 0a5836d debian / rules
0a5836d

Tree @0a5836d (Download .tar.gz)

rules @0a5836draw · history · blame

#!/usr/bin/make -f
# -*- mode: makefile; coding: utf-8 -*-
# Copyright 2015 Jonas Smedegaard <dr@jones.dk>
# Description: Main Debian packaging script for Log
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation; either version 3, or (at your option)
# any later version.
#
# This program is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
# General Public License for more details.
#
# You should have received a copy of the GNU General Public License
# along with this program.  If not, see <http://www.gnu.org/licenses/>.

# These need to be declared before CDBS includes
pkg = $(DEB_SOURCE_PACKAGE)
DEB_PYTHON_SUGAR_PACKAGES = $(pkg)

include /usr/share/cdbs/1/rules/upstream-tarball.mk
include /usr/share/cdbs/1/rules/utils.mk
include /usr/share/cdbs/1/class/python-sugar.mk
include /usr/share/cdbs/1/rules/debhelper.mk

DEB_UPSTREAM_PACKAGE = Log
DEB_UPSTREAM_URL = http://download.sugarlabs.org/sources/sucrose/fructose/$(DEB_UPSTREAM_PACKAGE)
DEB_UPSTREAM_TARBALL_EXTENSION = tar.bz2

DEB_SUGAR_PRIMARY_BRANCH = 0.86

# Suppress unneeded auto-resolved build-dependency on python-dev
CDBS_BUILD_DEPENDS_class_python-sugar_python = python

# Needed (always/often) at runtime
#  net-tools (/sbin/ifconfig /sbin/route) used in logcollect
#  procps (/bin/ps /usr/bin/free /usr/bin/top) used in logcollect
CDBS_DEPENDS_$(pkg) = $(call cdbs_sugar_anybranchdeps,python-sugar python-sugar-toolkit)
CDBS_DEPENDS_$(pkg) += , python-hippocanvas, python-telepathy, python-gtk2, python-cjson
CDBS_RECOMMENDS_$(pkg) = $(call cdbs_sugar_anybranchdeps,sugar)
CDBS_RECOMMENDS_$(pkg) +=, net-tools, procps