Codebase list teckit / 4cfeb1fc-bb08-40a3-8ba1-9f586d64b9df/main debian / rules
4cfeb1fc-bb08-40a3-8ba1-9f586d64b9df/main

Tree @4cfeb1fc-bb08-40a3-8ba1-9f586d64b9df/main (Download .tar.gz)

rules @4cfeb1fc-bb08-40a3-8ba1-9f586d64b9df/mainraw · history · blame

#!/usr/bin/make -f

DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
export DEB_BUILD_MAINT_OPTIONS = hardening=+all

%:
	dh $@ --with pkgkde_symbolshelper

override_dh_clean:
	dh_clean -X.orig

override_dh_install:
	chrpath -d debian/tmp/usr/bin/* debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/*so*
	dh_install

override_dh_auto_test:
	: do nothing here, otherwise test suite is executed