Codebase list teckit / ed62690 debian / patches / patch-02-warning
ed62690

Tree @ed62690 (Download .tar.gz)

patch-02-warning @ed62690raw · history · blame

From: texlive-bin package <debian-tex-maint@lists.debian.org>
	Avoid compiler warning.

diff -ur teckit-2.5.8/source/Compiler.h teckit-src/source/Compiler.h
--- teckit-2.5.8/source/Compiler.h	Tue Dec 05 07:20:20 2017
+++ teckit-src/source/Compiler.h	Tue Jul 24 07:21:23 2018
@@ -230,7 +230,7 @@
 		vector<UInt32>		byteClassLines;
 		vector<UInt32>		uniClassLines;
 
-		long				passType;
+		UInt32				passType;
 		UInt32				uniDefault;
 		UInt8				byteDefault;
 		bool				supplementaryChars;