diff --git a/ChangeLog b/ChangeLog index d49c5cd..0783f3a 100644 --- a/ChangeLog +++ b/ChangeLog @@ -1,3 +1,91 @@ +commit 134752a6e93b0c7d74482d1a0dc1a250c244c7f8 +Author: Will Thompson +Date: Thu Jul 14 16:27:10 2011 +0100 + + Version 0.23.3 + +commit ea0b99467075338861dc4d546077dcacc76d6da5 +Author: Will Thompson +Date: Thu Jul 14 16:26:35 2011 +0100 + + NEWS for 0.23.3 + +commit e9fa42cd452d504013cb9164e4624b33477ed271 +Author: João Paulo Rechi Vita +Date: Sat Jun 4 19:35:53 2011 -0300 + + Adds UPLOAD_BRANCH_HOST command-line variable + + This fixes upload-branch output. + + Signed-off-by: Will Thompson + +commit bf4b8aa9ebda7ba40ee907b09948c7ff739e34cc +Merge: 169dbed fc38a62 +Author: Danielle Madeley +Date: Fri Jun 24 16:40:09 2011 +0800 + + Merge branch 'css-trivia' + +commit 169dbedc698181b5d577a86fcc1217ccad0a06d6 +Author: Guillaume Desmottes +Date: Thu Jun 23 11:00:53 2011 +0200 + + Add a favicon to the generated HTML spec (#38594) + +commit fc38a620798f1e03f318bf5a152d227f7bc3084c +Author: Danielle Madeley +Date: Tue Jun 21 20:18:53 2011 +0800 + + Fix CSS for anchors in WebKit + + WebKit was ignoring the CSS to adjust the position of anchors for the fixed + title bar. The fix is to make the anchor a block element. + +commit b68efdb1af6bccd466fed919c64190bad3677f47 +Author: Danielle Madeley +Date: Mon Jun 13 15:32:13 2011 +0100 + + Add ChannelRequest hint ofdT.ChannelRequest.DelegateToPreferredHandler + + Fixes: https://bugs.freedesktop.org/show_bug.cgi?id=38240 + +commit 187fc7231eaa871db81466f70a99edfbdb95eed8 +Author: Xavier Claessens +Date: Mon May 30 09:43:35 2011 +0200 + + Set immutable and requestable tags on FileTransfer properties + +commit fc63a2603b8c92b61d30398ce463e343353f7336 +Author: Xavier Claessens +Date: Sun May 29 17:49:58 2011 +0200 + + Approvers can set URI on FileTransfer channels + +commit 13355a79437fb52b8e735b1f1fc7aa62ba24991c +Author: David Laban +Date: Tue May 24 22:04:06 2011 -0400 + + Add original-message-{sent,received} + + This is required by the logger, and also makes it unambiguous that + the message-{sent,received} of the Message refer to that of the the edit, + rather than that of the original message. + +commit 02059b91d902edab8d1464dc26d8abc62e396ca9 +Author: David Laban +Date: Tue May 24 22:00:10 2011 -0400 + + Clarify the acceptable forms for supersedes + + As discussed on fd.o#37413 + +commit 2eb580aed6ef088117041d2a1b4938a597b3e82b +Author: Guillaume Desmottes +Date: Mon May 16 10:43:48 2011 +0200 + + bump + commit da539f3e06ba711004974d28c7c90411c7e2b8ad Author: Guillaume Desmottes Date: Mon May 16 10:37:47 2011 +0200 diff --git a/Makefile b/Makefile index 8c9398f..1063e4b 100644 --- a/Makefile +++ b/Makefile @@ -91,14 +91,15 @@ rm -rf tmp/"$(DISTNAME)" BRANCH = $(shell sh tools/git-which-branch.sh misc | tr -d '\n' | tr -C "[:alnum:]" _) -UPLOAD_BRANCH_TO = people.freedesktop.org:public_html/telepathy-spec +UPLOAD_BRANCH_HOST = people.freedesktop.org +UPLOAD_BRANCH_TO = $(UPLOAD_BRANCH_HOST):public_html/telepathy-spec # Usage: make upload-branch BRANCH=discussion upload-branch: all rsync -rzvP --delete doc/spec \ $(UPLOAD_BRANCH_TO)-$(BRANCH)/ @echo Your spec branch might be at: - @echo ' ' http://people.freedesktop.org/~$$USER/telepathy-spec-$(BRANCH)/spec/ + @echo ' ' http://$(UPLOAD_BRANCH_HOST)/~$$USER/telepathy-spec-$(BRANCH)/spec/ # automake requires these rules for anything that's in DIST_SUBDIRS distclean: clean diff --git a/NEWS b/NEWS index b0098f6..f42a85b 100644 --- a/NEWS +++ b/NEWS @@ -1,6 +1,37 @@ This file contains the same edited highlights as the announcement emails. For full details, see the ChangeLog in tarballs, or "git log" in Git checkouts. + +telepathy-spec 0.23.3 (2011-07-14) +================================== + +API additions and clarifications: + +• The semantics of the 'supersedes' header in Messages have been clarified, and + 'original-message-sent' and 'original-message-received' headers have been + defined to make the timestamps used for message edits unambiguous. + (fd.o#37413, David) + +• A tonne of properties on FileTransfer have been marked as requestable and/or + immutable. Also, as a clarification, the spec now explicitly says that + approvers may set the URI property, and that handlers MUST obey this. + (Xavier) + +• A new ChannelRequest hint, DelegateToPreferredHandler, has been added. + (fd.o#38240, Danni) + +Spec HTML improvements: + +• Jumping to anchors within the spec HTML will no longer move the text you're + looking for underneath the title bar with Webkit. Yay! (Danni (my heroine)) + +• The generated HTML spec now has a beautiful favicon. (fd.o#38594, Guillaume) + +And for spec developers: + +• `make upload-branch` now takes an optional UPLOAD_BRANCH_TO Makefile + variable, which allows you to override the default server, namely + “people.freedesktop.org” (João Paulo Rechi Vita) telepathy-spec 0.23.2 (2011-05-16) ================================== diff --git a/doc/templates/errors.html b/doc/templates/errors.html index 4e231a7..94a793e 100644 --- a/doc/templates/errors.html +++ b/doc/templates/errors.html @@ -4,6 +4,7 @@ Errors +
diff --git a/doc/templates/favicon.png b/doc/templates/favicon.png new file mode 100644 index 0000000..cd58a71 Binary files /dev/null and b/doc/templates/favicon.png differ diff --git a/doc/templates/fullindex.html b/doc/templates/fullindex.html index a78116b..df66e52 100644 --- a/doc/templates/fullindex.html +++ b/doc/templates/fullindex.html @@ -5,6 +5,7 @@ Full Index + #set $star = [] diff --git a/doc/templates/generic-types.html b/doc/templates/generic-types.html index 87f72f7..21e9826 100644 --- a/doc/templates/generic-types.html +++ b/doc/templates/generic-types.html @@ -4,6 +4,7 @@ Generic Types +
diff --git a/doc/templates/index.html b/doc/templates/index.html index 90fdb2b..2df515d 100644 --- a/doc/templates/index.html +++ b/doc/templates/index.html @@ -4,6 +4,7 @@ $spec.title — v$spec.version +
diff --git a/doc/templates/interface.html b/doc/templates/interface.html index 3286010..1962748 100644 --- a/doc/templates/interface.html +++ b/doc/templates/interface.html @@ -4,6 +4,7 @@ $interface.really_short_name — $spec.title + diff --git a/doc/templates/interfaces.html b/doc/templates/interfaces.html index acf110c..d3c5fee 100644 --- a/doc/templates/interfaces.html +++ b/doc/templates/interfaces.html @@ -4,6 +4,7 @@ $spec.title — v$spec.version +
diff --git a/doc/templates/style.css b/doc/templates/style.css index fa07045..45ce833 100644 --- a/doc/templates/style.css +++ b/doc/templates/style.css @@ -49,8 +49,9 @@ } div.main a[name] { + display: block; position: relative; - top: -4.5em; + top: -5em; } div.outset { diff --git a/spec/Channel_Interface_Messages.xml b/spec/Channel_Interface_Messages.xml index 62e8384..a684bbc 100644 --- a/spec/Channel_Interface_Messages.xml +++ b/spec/Channel_Interface_Messages.xml @@ -599,15 +599,66 @@
supersedes (s – Protocol_Message_Token)
If present, this message supersedes a previous message, - identified by its protocol-token or - message-token header. The user interface MAY, for - example, choose to replace the superseded message with this - message, or grey out the superseded message. + identified by its message-token header. The user + interface MAY, for example, choose to replace the superseded + message with this message, or grey out the superseded message. Skype, for example, allows the user to amend messages they have already sent (to correct typos, etc.). -
+ + Connection Managers SHOULD represent repeatedly edited messages + in the following form: +
+                message {token = a};
+                message {token = b, supersedes = a};
+                message {token = c, supersedes = a};
+              
+ + The alternative form is: +
+                  message {token = a};
+                  message {token = b, supersedes = a};
+                  message {token = c, supersedes = b};
+                
+ but it is more difficult to implement in UIs/loggers, and it + breaks irrecoverably if message b is lost. If a CM is forced + to use this form, it should be tested extensively for + interoperability with existing clients. +
+ + Clients should deal gracefully if the original message gets + lost, but one or more corrections to it get through: +
+                message {token = x} gets lost;
+                message {token = y, supersedes = x};
+                message {token = z, supersedes = x};
+              
+ + This is the form that CMs will use to mean "I know + that this message was edited, but I don't know what it + originally said." It is often in the interests of the + remote side for message x to be lost (e.g. to hide + embarassing mistakes or sensitive information) so it might not + be possible to retrieve it (even on protocols with reliable + message-delivery guarantees). + +
original-message-sent (x - Unix_Timestamp64)
+
The message-sent header of the message that this + one supersedes. + This key should only be present if supersedes is also + present. It MAY be used as a hint to help clients locate the + original message in its logs. If present, comparing the tuple + (original-message-sent, supersedes) with (message-sent, + message-token) SHOULD be enough to uniquely + identify the original message.
+ +
original-message-received (x - Unix_Timestamp64)
+
The message-received header of the message that this + one supersedes. + This key should only be present if supersedes is also + present. It MAY be used as a hint in a similar way to + original-message-sent.
pending-message-id (u - Message_ID)
The incoming message ID. This MUST NOT be present on outgoing diff --git a/spec/Channel_Request.xml b/spec/Channel_Request.xml index fbb6792..dd10049 100644 --- a/spec/Channel_Request.xml +++ b/spec/Channel_Request.xml @@ -218,7 +218,7 @@

A dictionary of metadata provided by the channel requester, which the handler and other clients MAY choose to - interpret. Currently no standard keys are defined; clients MAY + interpret. Clients MAY choose to use platform-specific keys for their own purposes, but MUST ignore unknown keys and MUST cope with expected keys being missing. Clients SHOULD namespace hint names by having them @@ -249,6 +249,48 @@ namespace="ofdT.Client.Interface.Requests">AddRequest by the ChannelDispatcher.

+

The following standardised hints are defined:

+ +
+
org.freedesktop.Telepathy.ChannelRequest.DelegateToPreferredHandler - b
+
If present and True the client currently handling the channel + SHOULD pass the channel to the + PreferredHandler using + DelegateChannels. + + + This hint allows the user to request a channel in their + preferred client in a situation where there are two chat + handlers (for example: requesting a channel in Empathy which is + currently being handled by gnome-shell). + + + If the channel is currently unhandled, clients SHOULD ignore this + hint. + + + It is assumed that Mission Control will correctly delegate an + unhandled channel to the preferred Handler. This allows + requesting clients to always include this hint in their channel + request. + + + The Handler should check each + ChannelRequest + of the Requests_Satisfied parameter of + HandleChannels + for the hint. The first request containing the hint SHOULD be used + and all further hints SHOULD be ignored. + + + This covers the very unlikely case where + HandleChannels + satisfies two separate requests which have different + PreferredHandlers. + +
+
+
diff --git a/spec/Channel_Type_File_Transfer.xml b/spec/Channel_Type_File_Transfer.xml index 6963d21..f50b963 100644 --- a/spec/Channel_Type_File_Transfer.xml +++ b/spec/Channel_Type_File_Transfer.xml @@ -96,7 +96,7 @@ + tp:name-for-bindings="Content_Type" tp:immutable="yes" tp:requestable="yes">

The file's MIME type. This cannot change once the channel has been created.

@@ -109,7 +109,7 @@
+ tp:name-for-bindings="Filename" tp:immutable="yes" tp:requestable="yes">

The name of the file on the sender's side. This is therefore given as a suggested filename for the receiver. This cannot change @@ -126,7 +126,7 @@ + tp:name-for-bindings="Size" tp:immutable="yes" tp:requestable="yes">

The size of the file. If this property is set, then the file transfer is guaranteed to be this size. This cannot change once @@ -145,7 +145,8 @@ + access="read" tp:name-for-bindings="Content_Hash_Type" tp:immutable="yes" + tp:requestable="yes">

The type of the ContentHash property.

@@ -168,7 +169,8 @@
+ tp:name-for-bindings="Content_Hash" tp:immutable="yes" + tp:requestable="yes">

Hash of the contents of the file transfer, of type described in the value of the ContentHashType @@ -184,7 +186,7 @@ + tp:name-for-bindings="Description" tp:immutable="yes" tp:requestable="yes">

Description of the file transfer. This cannot change once the channel has been created.

@@ -197,7 +199,8 @@
+ tp:type="Unix_Timestamp64" tp:name-for-bindings="Date" tp:immutable="yes" + tp:requestable="yes">

The last modification time of the file being transferred. This cannot change once the channel has been created

@@ -210,7 +213,8 @@ + tp:name-for-bindings="Available_Socket_Types" + tp:immutable="yes" tp:requestable="yes">

A mapping from address types (members of Socket_Address_Type) to arrays of access-control type (members of Socket_Access_Control) @@ -243,7 +247,7 @@ + tp:name-for-bindings="Initial_Offset" tp:requestable="yes">

The offset in bytes from where the file should be sent. This MUST be respected by both the receiver and the sender after the state @@ -276,7 +280,8 @@

For incoming file transfers, this property MAY be set by the channel handler before calling AcceptFile to - inform observers where the incoming file will be saved. + inform observers where the incoming file will be saved. If set by an + approver, the handler MUST save the file to that location. Setting this property once AcceptFile has been called MUST fail. Once this property has been set URIDefined is emitted.

diff --git a/spec/all.xml b/spec/all.xml index ca6689f..68fd699 100644 --- a/spec/all.xml +++ b/spec/all.xml @@ -3,7 +3,7 @@ xmlns:xi="http://www.w3.org/2001/XInclude"> Telepathy D-Bus Interface Specification -0.23.2 +0.23.3 Copyright © 2005-2011 Collabora Limited Copyright © 2005-2011 Nokia Corporation diff --git a/tools/doc-generator.py b/tools/doc-generator.py index 95a8011..6117a6c 100755 --- a/tools/doc-generator.py +++ b/tools/doc-generator.py @@ -58,6 +58,7 @@ 'jquery.min.js', 'ui-icons_222222_256x240.png', 'magic.js', + 'favicon.png' ] for s in static: shutil.copy(os.path.join(template_path, s), output_path)