Codebase list tigr-glimmer / a1e48a6 debian / patches / 10_gcc4.4.patch
a1e48a6

Tree @a1e48a6 (Download .tar.gz)

10_gcc4.4.patch @a1e48a6raw · history · blame

Author: Andreas Tille <tille@debian.org>
Description: Fix FTBFS #560442

--- a/src/Common/gene.cc
+++ b/src/Common/gene.cc
@@ -444,7 +444,7 @@ int  Char_Sub
 //  Return a subscript corresponding to character  ch .
 
   {
-   char  * p;
+   const char  * p;
 
    p = strchr (CONVERSION_STRING, tolower (ch));
    if  (p == NULL)
--- a/src/ICM/icm.cc
+++ b/src/ICM/icm.cc
@@ -1983,7 +1983,7 @@ int  Subscript
 //  model) for character  ch .
 
   {
-   char  * p;
+   const char  * p;
 
    p = strchr (ALPHA_STRING, tolower (Filter (ch)));
    if  (p == NULL)