Add patches to place output format files in $SHAREDIR/unrtf
To conform with FHS
Willi Mann
10 years ago
|
0 |
From: Willi Mann <willi@wm1.at>
|
|
1 |
Date: Sun, 23 Dec 2012 21:21:46 +0100
|
|
2 |
Subject: Hand over SHAREDIR via CPPFLAGS
|
|
3 |
|
|
4 |
---
|
|
5 |
src/Makefile.am | 2 ++
|
|
6 |
1 file changed, 2 insertions(+)
|
|
7 |
|
|
8 |
diff --git a/src/Makefile.am b/src/Makefile.am
|
|
9 |
index d6017b3..8a521fe 100644
|
|
10 |
--- a/src/Makefile.am
|
|
11 |
+++ b/src/Makefile.am
|
|
12 |
@@ -3,6 +3,8 @@
|
|
13 |
|
|
14 |
bin_PROGRAMS = unrtf
|
|
15 |
|
|
16 |
+AM_CPPFLAGS = -DSHAREDIR=\"$(sharedir)\"
|
|
17 |
+
|
|
18 |
unrtf_SOURCES = attr.c attr.h \
|
|
19 |
convert.c convert.h \
|
|
20 |
defs.h \
|
debian/patches/0002-Hand-over-SYSCONFDIR-via-CPPFLAGS.patch
less
more
0 | |
From: Willi Mann <willi@wm1.at>
|
1 | |
Date: Sun, 23 Dec 2012 21:21:46 +0100
|
2 | |
Subject: Hand over SYSCONFDIR via CPPFLAGS
|
3 | |
|
4 | |
---
|
5 | |
src/Makefile.am | 2 ++
|
6 | |
1 file changed, 2 insertions(+)
|
7 | |
|
8 | |
diff --git a/src/Makefile.am b/src/Makefile.am
|
9 | |
index d6017b3..4930a97 100644
|
10 | |
--- a/src/Makefile.am
|
11 | |
+++ b/src/Makefile.am
|
12 | |
@@ -3,6 +3,8 @@
|
13 | |
|
14 | |
bin_PROGRAMS = unrtf
|
15 | |
|
16 | |
+AM_CPPFLAGS = -DSYSCONFDIR=\"$(sysconfdir)\"
|
17 | |
+
|
18 | |
unrtf_SOURCES = attr.c attr.h \
|
19 | |
convert.c convert.h \
|
20 | |
defs.h \
|
debian/patches/0003-Make-CONFIG_DIR-depend-on-SYSCONFDIR.patch
less
more
0 | |
From: Willi Mann <willi@wm1.at>
|
1 | |
Date: Sun, 23 Dec 2012 21:42:19 +0100
|
2 | |
Subject: Make CONFIG_DIR depend on SYSCONFDIR
|
3 | |
|
4 | |
---
|
5 | |
src/main.h | 2 +-
|
6 | |
1 file changed, 1 insertion(+), 1 deletion(-)
|
7 | |
|
8 | |
diff --git a/src/main.h b/src/main.h
|
9 | |
index 4230d47..3e0834e 100644
|
10 | |
--- a/src/main.h
|
11 | |
+++ b/src/main.h
|
12 | |
@@ -47,7 +47,7 @@ extern int no_remap_mode;
|
13 | |
#include "output.h"
|
14 | |
#endif
|
15 | |
|
16 | |
-#define CONFIG_DIR "/usr/local/lib/unrtf/"
|
17 | |
+#define CONFIG_DIR SYSCONFDIR "/unrtf/"
|
18 | |
#define DEFAULT_OUTPUT "html"
|
19 | |
|
20 | |
extern OutputPersonality *op;
|
|
0 |
From: Willi Mann <willi@wm1.at>
|
|
1 |
Date: Sun, 23 Dec 2012 21:42:19 +0100
|
|
2 |
Subject: Make $SHAREDIR/unrtf default path for output format configuration
|
|
3 |
|
|
4 |
---
|
|
5 |
src/main.h | 2 +-
|
|
6 |
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
7 |
|
|
8 |
diff --git a/src/main.h b/src/main.h
|
|
9 |
index 4230d47..0fc8a46 100644
|
|
10 |
--- a/src/main.h
|
|
11 |
+++ b/src/main.h
|
|
12 |
@@ -47,7 +47,7 @@ extern int no_remap_mode;
|
|
13 |
#include "output.h"
|
|
14 |
#endif
|
|
15 |
|
|
16 |
-#define CONFIG_DIR "/usr/local/lib/unrtf/"
|
|
17 |
+#define CONFIG_DIR SHAREDIR "/unrtf/"
|
|
18 |
#define DEFAULT_OUTPUT "html"
|
|
19 |
|
|
20 |
extern OutputPersonality *op;
|
debian/patches/0004-Place-config-files-in-sysconfdir-instead-of-libdir.patch
less
more
0 | |
From: Willi Mann <willi@wm1.at>
|
1 | |
Date: Sun, 23 Dec 2012 21:44:58 +0100
|
2 | |
Subject: Place config files in sysconfdir instead of libdir
|
3 | |
|
4 | |
---
|
5 | |
outputs/Makefile.am | 2 +-
|
6 | |
1 file changed, 1 insertion(+), 1 deletion(-)
|
7 | |
|
8 | |
diff --git a/outputs/Makefile.am b/outputs/Makefile.am
|
9 | |
index 055b75e..a1cc8cc 100644
|
10 | |
--- a/outputs/Makefile.am
|
11 | |
+++ b/outputs/Makefile.am
|
12 | |
@@ -1,2 +1,2 @@
|
13 | |
-outputsdir = ${libdir}/${PACKAGE}
|
14 | |
+outputsdir = ${sysconfdir}/${PACKAGE}
|
15 | |
dist_outputs_DATA = html.conf latex.conf rtf.conf text.conf vt.conf
|
|
0 |
From: Willi Mann <willi@wm1.at>
|
|
1 |
Date: Sun, 23 Dec 2012 21:44:58 +0100
|
|
2 |
Subject: Place output config files in sharedir instead of libdir
|
|
3 |
|
|
4 |
---
|
|
5 |
outputs/Makefile.am | 2 +-
|
|
6 |
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
7 |
|
|
8 |
diff --git a/outputs/Makefile.am b/outputs/Makefile.am
|
|
9 |
index 055b75e..74fd3cc 100644
|
|
10 |
--- a/outputs/Makefile.am
|
|
11 |
+++ b/outputs/Makefile.am
|
|
12 |
@@ -1,2 +1,2 @@
|
|
13 |
-outputsdir = ${libdir}/${PACKAGE}
|
|
14 |
+outputsdir = ${sharedir}/${PACKAGE}
|
|
15 |
dist_outputs_DATA = html.conf latex.conf rtf.conf text.conf vt.conf
|
0 | 0 |
0001-Fix-manpage-section-specification.patch
|
1 | |
0002-Hand-over-SYSCONFDIR-via-CPPFLAGS.patch
|
2 | |
0003-Make-CONFIG_DIR-depend-on-SYSCONFDIR.patch
|
3 | |
0004-Place-config-files-in-sysconfdir-instead-of-libdir.patch
|
|
1 |
0002-Hand-over-SHAREDIR-via-CPPFLAGS.patch
|
|
2 |
0003-Make-SHAREDIR-unrtf-default-path-for-output-format-c.patch
|
|
3 |
0004-Place-output-config-files-in-sharedir-instead-of-lib.patch
|