Codebase list votca-xtp / debian/1.5-1 debian / rules
debian/1.5-1

Tree @debian/1.5-1 (Download .tar.gz)

rules @debian/1.5-1raw · history · blame

#!/usr/bin/make -f
#export DH_VERBOSE = 1

export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed

export CTEST_OUTPUT_ON_FAILURE = On

override_dh_auto_configure:
	dh_auto_configure -- -DENABLE_TESTING=On -DBUILD_MANPAGES=On

# Some tests are unstable.  Run them, but don't fail on them just yet.
override_dh_auto_test:
	-dh_auto_test

override_dh_installman:
	dh_installman --sourcedir=$(CURDIR)/debian/man

%:
	dh $@ --with python2