Codebase list xapp / 6ce5ba6 debian / rules
6ce5ba6

Tree @6ce5ba6 (Download .tar.gz)

rules @6ce5ba6raw · history · blame

#!/usr/bin/make -f

export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed -Wl,-z,now

%:
	dh $@ --with=gir,python3

override_dh_auto_configure:
	dh_auto_configure -- \
		--libexecdir=/usr/libexec \
		-D docs=true \
		-D deprecated_warnings=false \
		--buildtype=debugoptimized

override_dh_strip:
	dh_strip --dbg-package=libxapp-dbg