Codebase list xapp / 72876f0e-7b82-4cb4-b809-866057c0d96f/main debian / rules
72876f0e-7b82-4cb4-b809-866057c0d96f/main

Tree @72876f0e-7b82-4cb4-b809-866057c0d96f/main (Download .tar.gz)

rules @72876f0e-7b82-4cb4-b809-866057c0d96f/mainraw · history · blame

#!/usr/bin/make -f

include /usr/share/dpkg/architecture.mk

export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed -Wl,-z,now

%:
	dh $@ --with=gir,python3

override_dh_auto_configure:
	dh_auto_configure -- \
	    -D libexecdir=lib/$(DEB_TARGET_MULTIARCH) \
	    -D docs=true \
	    -D deprecated_warnings=false

#
# between xapp 2.0.0 and 2.0.1, upstream switched from installing
# the Xsession file into /etc/X11/Xsession.d/ to /etc/X11/xinit/xinitrc.d/
# Debian does not support the later, but Xinit load the Xsession.
# Thus, undo this changes here
execute_before_dh_install:
	mkdir -p debian/tmp/etc/X11/Xsession.d/
	mv debian/tmp/etc/X11/xinit/xinitrc.d/80xapp-gtk3-module.sh \
	   debian/tmp/etc/X11/Xsession.d/80xapp-gtk3-module
	chmod 0644 debian/tmp/etc/X11/Xsession.d/80xapp-gtk3-module
	rmdir debian/tmp/etc/X11/xinit/xinitrc.d
	rmdir debian/tmp/etc/X11/xinit