Codebase list xapp / 9e2566e debian / rules
9e2566e

Tree @9e2566e (Download .tar.gz)

rules @9e2566eraw · history · blame

#!/usr/bin/make -f

# FIXME: much of this can be removed once we move off of xenial/mint 18 base support
# meson support is baked in

%:
	dh $@ --parallel --with=gir,python3

override_dh_auto_configure:
	mkdir -p debian/build
	meson debian/build \
		--prefix=/usr \
		--buildtype=plain \
		-Ddeprecation_flags=true

override_dh_strip:
	dh_strip --dbg-package=libxapp-dbg

override_dh_auto_build:
	ninja -C debian/build

override_dh_auto_test:
	ninja -C debian/build test

override_dh_auto_install:
	DESTDIR=${CURDIR}/debian/tmp \
	ninja -C debian/build install