diff --git a/debian/changelog b/debian/changelog index 29b701b..ca819a6 100644 --- a/debian/changelog +++ b/debian/changelog @@ -1,3 +1,64 @@ +xapp (1.6.10) tricia; urgency=medium + + [ Michael Webster ] + * xapp-status-icon.c: Sync the visible state of the fallback GtkStatusIcon when it is first created. + * xapp-status-icon.c: Fix the timeout duration for xapp_status_icon_any_monitors. + + -- Clement Lefebvre Thu, 09 Jan 2020 17:13:49 +0000 + +xapp (1.6.9) tricia; urgency=medium + + [ Michael Webster ] + * xapp-icon-chooser-dialog.c: fix hidpi icon rendering and spacing. + + [ Clement Lefebvre ] + * l10n: Update translations + + [ Michael Webster ] + * xapp-status-icon.c: Allow a primary-click to activate appindicator icons when they have set a 'secondary activate' target. Otherwise, have primary open the menu as it ordinarily would. + + -- Clement Lefebvre Tue, 07 Jan 2020 10:21:15 +0000 + +xapp (1.6.8) tricia; urgency=medium + + * l10n: Update translations + + -- Clement Lefebvre Wed, 11 Dec 2019 14:57:44 +0000 + +xapp (1.6.7) tricia; urgency=medium + + [ Michael Webster ] + * xapp-status-icon.c: Reposition the menu when part of it would end up below the workarea of the monitor. + * mate-xapp-status-applet.py: Call widget.show_all() before binding to the proxy's visible property. The binding is one way only - local changes can override the state initially set by the proxy. + + -- Clement Lefebvre Tue, 10 Dec 2019 09:48:37 +0000 + +xapp (1.6.6) tricia; urgency=medium + + [ Michael Webster ] + * mate-xapp-status-applet.py: Add a small margin at either end of the applet, and allow ctrl-right-clicks anywhere on it, so the user can bring up the About menu. + + -- Clement Lefebvre Wed, 04 Dec 2019 16:24:15 +0000 + +xapp (1.6.5) tricia; urgency=medium + + [ Michael Webster ] + * mate-xapp-status-applet.py: Hardcode symbolic icons to 22px. + + -- Clement Lefebvre Fri, 29 Nov 2019 18:33:05 +0000 + +xapp (1.6.4) tricia; urgency=medium + + * Mate applet: Don't use a handle + + -- Clement Lefebvre Thu, 28 Nov 2019 19:58:37 +0000 + +xapp (1.6.3) tricia; urgency=medium + + * l10n: Update translations + + -- Clement Lefebvre Tue, 26 Nov 2019 17:11:36 +0000 + xapp (1.6.2) tricia; urgency=medium [ Eli Schwartz ] diff --git a/docs/reference/XAppStatusIcon.html b/docs/reference/XAppStatusIcon.html index b9e166a..fec567a 100644 --- a/docs/reference/XAppStatusIcon.html +++ b/docs/reference/XAppStatusIcon.html @@ -122,6 +122,22 @@ xapp_status_icon_get_secondary_menu () + + +XAppStatusIconState + + +xapp_status_icon_get_state () + + + + +gboolean + + +xapp_status_icon_any_monitors () + + @@ -173,6 +189,11 @@ button-release-event Action + +void +state-changed +Action + @@ -189,6 +210,10 @@ XAPP_TYPE_STATUS_ICON +enum +XAppStatusIconState + +   XAppStatusIcon @@ -197,7 +222,9 @@

Object Hierarchy

-
    GObject
+
    GEnum
+    ╰── XAppStatusIconState
+    GObject
     ╰── XAppStatusIcon
 
@@ -498,6 +525,48 @@

Since: 1.6

+
+
+

xapp_status_icon_get_state ()

+
XAppStatusIconState
+xapp_status_icon_get_state (XAppStatusIcon *icon);
+

Gets the current XAppStatusIconState of icon. The state is determined by whether +the icon is being displayed by an XAppStatusMonitor client, a fallback tray icon, +or not being displayed at all.

+

See XAppStatusIconState for more details.

+
+

Parameters

+
+++++ + + + + + +

icon

an XAppStatusIcon

 
+
+
+

Returns

+

the icon's state.

+
+

Since: 1.6

+
+
+
+

xapp_status_icon_any_monitors ()

+
gboolean
+xapp_status_icon_any_monitors (void);
+

Looks for the existence of any active XAppStatusIconMonitors on the bus.

+
+

Returns

+

TRUE if at least one monitor was found.

+
+

Since: 1.6

+

Types and Values

@@ -505,6 +574,46 @@

XAPP_TYPE_STATUS_ICON

#define XAPP_TYPE_STATUS_ICON            (xapp_status_icon_get_type ())
 
+
+
+
+

enum XAppStatusIconState

+
+

Members

+
+++++ + + + + + + + + + + + + + + + + + +

XAPP_STATUS_ICON_STATE_NATIVE

+

The XAppStatusIcon is currently being handled +by an XAppStatusIconMonitor (usually in an applet).

+
 

XAPP_STATUS_ICON_STATE_FALLBACK

+

The XAppStatusIcon is currently being handled +by a legacy system tray implementation (using GtkStatusIcon).

+
 

XAPP_STATUS_ICON_STATE_NO_SUPPORT

+

The XAppStatusIcon is not currently being handled by any +kind of status icon implementation.

+
 
+

@@ -718,6 +827,46 @@

Flags: Action

+
+
+

The “state-changed” signal

+
void
+user_function (XAppStatusIcon     *icon,
+               XAppStatusIconState new_state,
+               gpointer            user_data)
+

Gets emitted when the state of the icon changes. If you wish +to react to changes in how the status icon is being handled +(perhaps to alter the menu or other click behavior), you should +connect to this - see XAppStatusIconState for more details.

+
+

Parameters

+
+++++ + + + + + + + + + + + + + + + + + +

icon

The XAppStatusIcon

 

new_state

The new XAppStatusIconState of the icon

 

user_data

user data set when the signal handler was connected.

 
+
+

Flags: Action

+