Package list xapp / fd4881f6-9bf9-4828-a7a2-4888d33cbd11/main
Reading package lists... 0%Reading package lists... 0%Reading package lists... 0%Reading package lists... 99%Reading package lists... 99%Reading package lists... Done Building dependency tree... 0%Building dependency tree... 0%Building dependency tree... 50%Building dependency tree... 50%Building dependency tree... Done Reading state information... 0% Reading state information... 0%Reading state information... Done Connecting to api.ftp-master.debian.org to check 24 package versions. Please wait... Got info from api.ftp-master.debian.org for 24 packages. Config::Model::Backend::DpkgSyntax::parse_dpkg_lines No section found in file debian/patches/remap-archall-libexec (line 149) Changes applied to dpkg configuration: - control source Standards-Version: '4.5.0' -> '4.6.0' # applied fix for :Current standards version is '4.6.0'. Please read https://www.debian.org/doc/debian-policy/upgrading-checklist.html for the changes that may be needed on your package to upgrade it from standard version '4.5.0' to '4.6.0'. - control source Build-Depends:2: 'dpkg-dev (>= 1.15.1)' -> 'dpkg-dev' # applied fix for :unnecessary greater-than versioned dependency: dpkg-dev (>= 1.15.1). Debian has oldstable -> 1.19.7; stable -> 1.20.9; unstable -> 1.20.9; testing -> 1.20.9; - control source Build-Depends:3: 'gobject-introspection (>= 0.10.2-1~)' -> 'gobject-introspection' # applied fix for :unnecessary greater-than versioned dependency: gobject-introspection (>= 0.10.2-1~). Debian has oldstable -> 1.58.3-2; stable -> 1.66.1-1+b1; unstable -> 1.68.0-2; testing -> 1.68.0-2; - control source Build-Depends:4: 'gtk-doc-tools (>= 1.4)' -> 'gtk-doc-tools' # applied fix for :unnecessary greater-than versioned dependency: gtk-doc-tools (>= 1.4). Debian has oldstable -> 1.28-1; stable -> 1.33.2-1; unstable -> 1.33.2-1; testing -> 1.33.2-1; - control source Build-Depends:5: 'intltool (>= 0.40.6)' -> 'intltool' # applied fix for :unnecessary greater-than versioned dependency: intltool (>= 0.40.6). Debian has oldstable -> 0.51.0-5; unstable -> 0.51.0-6; testing -> 0.51.0-6; stable -> 0.51.0-6; - control source Build-Depends:7: 'libgdk-pixbuf2.0-dev (>= 2.22.0)' -> 'libgdk-pixbuf2.0-dev' # applied fix for :unnecessary greater-than versioned dependency: libgdk-pixbuf2.0-dev (>= 2.22.0). Debian has oldstable -> 2.38.1+dfsg-1; stable -> 2.40.2-2; unstable -> 2.40.2-2; testing -> 2.40.2-2; - control source Build-Depends:8: 'libgirepository1.0-dev (>= 0.10.2-1~)' -> 'libgirepository1.0-dev' # applied fix for :unnecessary greater-than versioned dependency: libgirepository1.0-dev (>= 0.10.2-1~). Debian has oldstable -> 1.58.3-2; stable -> 1.66.1-1+b1; unstable -> 1.68.0-2; testing -> 1.68.0-2; - control source Build-Depends:9: 'libglib2.0-dev (>= 2.37.3)' -> 'libglib2.0-dev' # applied fix for :unnecessary greater-than versioned dependency: libglib2.0-dev (>= 2.37.3). Debian has oldstable -> 2.58.3-2+deb10u3; stable -> 2.66.8-1; unstable -> 2.68.4-1; testing -> 2.68.4-1; - control source Build-Depends:11: 'libgtk-3-dev (>= 3.3.16)' -> 'libgtk-3-dev' # applied fix for :unnecessary greater-than versioned dependency: libgtk-3-dev (>= 3.3.16). Debian has oldstable -> 3.24.5-1; stable -> 3.24.24-4; unstable -> 3.24.30-3; testing -> 3.24.30-3; - control source Build-Depends:14: 'meson (>= 0.40.0)' -> 'meson' # applied fix for :unnecessary greater-than versioned dependency: meson (>= 0.40.0). Debian has stretch-backports -> 0.49.0-1~bpo9+1; oldstable -> 0.49.2-1; buster-backports -> 0.56.1-1~bpo10+1; stable -> 0.56.2-1; unstable -> 0.59.1-1; testing -> 0.59.1-1; - control binary:"libxapp-dev" Depends:2: 'libgtk-3-dev (>= 3.3.16)' -> 'libgtk-3-dev' # applied fix for :unnecessary greater-than versioned dependency: libgtk-3-dev (>= 3.3.16). Debian has oldstable -> 3.24.5-1; stable -> 3.24.24-4; unstable -> 3.24.30-3; testing -> 3.24.30-3; - patches:"remap-archall-libexec" Synopsis has new value: 'Remap archall libexec' # applied fix for :Empty synopsis Debian Janitor 2 months ago
2 changed file(s) with 67 addition(s) and 63 deletion(s). Raw diff Collapse all Expand all
00 Source: xapp
1 Maintainer: Debian Cinnamon Team <debian-cinnamon@lists.debian.org>
2 Uploaders: Maximiliano Curia <maxy@debian.org>,
3 Margarita Manterola <marga@debian.org>,
4 Norbert Preining <norbert@preining.info>
15 Section: x11
26 Priority: optional
3 Maintainer: Debian Cinnamon Team <debian-cinnamon@lists.debian.org>
4 Uploaders:
5 Maximiliano Curia <maxy@debian.org>,
6 Margarita Manterola <marga@debian.org>,
7 Norbert Preining <norbert@preining.info>
8 Build-Depends:
9 debhelper-compat (= 13),
10 dh-python,
11 dpkg-dev (>= 1.15.1),
12 gobject-introspection (>= 0.10.2-1~),
13 gtk-doc-tools (>= 1.4),
14 intltool (>= 0.40.6),
15 libdbusmenu-gtk3-dev,
16 libgdk-pixbuf2.0-dev (>= 2.22.0),
17 libgirepository1.0-dev (>= 0.10.2-1~),
18 libglib2.0-dev (>= 2.37.3),
19 libgnomekbd-dev,
20 libgtk-3-dev (>= 3.3.16),
21 libx11-dev,
22 libxkbfile-dev,
23 meson (>= 0.40.0),
24 python-gi-dev,
25 python3,
26 valac,
27 Standards-Version: 4.5.0
28 Homepage: http://cinnamon.linuxmint.com/
7 Build-Depends: debhelper-compat (= 13),
8 dh-python,
9 dpkg-dev,
10 gobject-introspection,
11 gtk-doc-tools,
12 intltool,
13 libdbusmenu-gtk3-dev,
14 libgdk-pixbuf2.0-dev,
15 libgirepository1.0-dev,
16 libglib2.0-dev,
17 libgnomekbd-dev,
18 libgtk-3-dev,
19 libx11-dev,
20 libxkbfile-dev,
21 meson,
22 python-gi-dev,
23 python3,
24 valac
25 Standards-Version: 4.6.0
2926 Vcs-Browser: https://salsa.debian.org/cinnamon-team/xapp
3027 Vcs-Git: https://salsa.debian.org/cinnamon-team/xapp.git
28 Homepage: http://cinnamon.linuxmint.com/
3129
3230 Package: gir1.2-xapp-1.0
31 Architecture: any
3332 Section: introspection
34 Architecture: any
35 Depends:
36 ${gir:Depends},
37 ${misc:Depends},
38 ${python3:Depends}
33 Depends: ${gir:Depends},
34 ${misc:Depends},
35 ${python3:Depends}
36 Breaks: cinnamon (<< 4.0),
37 cinnamon-screensaver (<< 4.0)
3938 Description: Introspection data for Xapp
4039 Xapp provides components which are common to multiple desktop environments
4140 and required to implement cross-DE solutions.
4241 .
4342 This package contains the introspection data for Xapp.
44 Breaks: cinnamon (<< 4.0), cinnamon-screensaver (<< 4.0)
4543
4644 Package: libxapp-dev
45 Architecture: any
4746 Section: libdevel
48 Architecture: any
49 Depends:
50 gir1.2-xapp-1.0 (= ${binary:Version}),
51 libgnomekbd-dev,
52 libgtk-3-dev (>= 3.3.16),
53 libxapp1 (= ${binary:Version}),
54 libxkbfile-dev,
55 ${misc:Depends},
47 Depends: gir1.2-xapp-1.0 (= ${binary:Version}),
48 libgnomekbd-dev,
49 libgtk-3-dev,
50 libxapp1 (= ${binary:Version}),
51 libxkbfile-dev,
52 ${misc:Depends}
5653 Description: XApp library - development files
5754 Xapp provides components which are common to multiple desktop environments
5855 and required to implement cross-DE solutions.
6158 library functions.
6259
6360 Package: libxapp1
64 Section: libs
6561 Architecture: any
6662 Multi-Arch: same
63 Section: libs
64 Depends: libgnomekbd8,
65 xapps-common (>= ${source:Version}),
66 ${misc:Depends},
67 ${shlibs:Depends}
6768 Pre-Depends: ${misc:Pre-Depends}
68 Depends:
69 libgnomekbd8,
70 xapps-common (>= ${source:Version}),
71 ${misc:Depends},
72 ${shlibs:Depends},
69 Breaks: nemo (<< 4.0),
70 xapps-common (<< 2.0.6-2~)
71 Replaces: xapps-common (<< 2.0.6-2~)
7372 Description: XApp library
7473 Xapp provides components which are common to multiple desktop environments
7574 and required to implement cross-DE solutions.
7675 .
7776 This library is used by several Xapp apps.
78 Replaces: xapps-common (<< 2.0.6-2~)
79 Breaks: nemo (<< 4.0), xapps-common (<< 2.0.6-2~)
8077
8178 Package: xapps-common
8279 Architecture: all
8380 Multi-Arch: foreign
84 Depends: python3, python3-gi, xdg-utils, ${misc:Depends}, ${python3:Depends}
85 Recommends: gist, inxi
81 Depends: python3,
82 python3-gi,
83 xdg-utils,
84 ${misc:Depends},
85 ${python3:Depends}
86 Recommends: gist,
87 inxi
88 Breaks: cinnamon (<< 4.0)
8689 Description: Files that are common across Xapp desktop applications
8790 Xapp provides components which are common to multiple desktop environments
8891 and required to implement cross-DE solutions.
8992 .
9093 This package includes files that are shared between several XApp
9194 apps (i18n files and configuration schemas).
92 Breaks: cinnamon (<< 4.0)
9395
9496 Package: xapps-doc
97 Architecture: all
9598 Section: doc
96 Architecture: all
97 Depends: devhelp, ${misc:Depends}
99 Depends: devhelp,
100 ${misc:Depends}
98101 Description: Libxapp documentation
99102 Xapp provides components which are common to multiple desktop environments
100103 and required to implement cross-DE solutions.
0 We are building with --Dlibexecdir=lib/$(DEB_TARGET_MULTIARCH) so that the
1 xapp-sn-watcher binary is correctly placed in an arch-dependent directory.
2
3 The other libexec files (applet_constants.py mate-xapp-status-applet.py)
4 are installed into arch-deps but arch-all package xapp1-common, and thus
5 cannot use the $(DEB_TARGET_MULTIARCH) directory.
6
7 Since the location of the Python files are not hard-coded in the source but
8 only in the service and desktop file, we install the .py into /usr/libexec,
9 and patch the service and aplet files to use the updated path.
0 Description: Remap archall libexec
1 We are building with --Dlibexecdir=lib/$(DEB_TARGET_MULTIARCH) so that the
2 xapp-sn-watcher binary is correctly placed in an arch-dependent directory.
3 .
4 The other libexec files (applet_constants.py mate-xapp-status-applet.py)
5 are installed into arch-deps but arch-all package xapp1-common, and thus
6 cannot use the $(DEB_TARGET_MULTIARCH) directory.
7 .
8 Since the location of the Python files are not hard-coded in the source but
9 only in the service and desktop file, we install the .py into /usr/libexec,
10 and patch the service and aplet files to use the updated path.
1011 ---
1112 status-applets/mate/org.mate.panel.applet.MateXAppStatusAppletFactory.service.in | 2 +-
1213 status-applets/mate/org.x.MateXAppStatusApplet.mate-panel-applet.in.in | 2 +-