Lintian Fixes - astromenace

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/astromenace lintian-fixes/main

Summary

  • Set debhelper-compat version in Build-Depends. (uses-debhelper-compat-file)
  • Remove obsolete fields Contact, Name from debian/upstream/metadata.

Diff

diff --git a/debian/changelog b/debian/changelog
index 383dc15..2ab15d7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+astromenace (1.3.2+repack-7) UNRELEASED; urgency=medium
+
+  * Set debhelper-compat version in Build-Depends.
+  * Remove obsolete fields Contact, Name from debian/upstream/metadata.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Wed, 20 Nov 2019 21:17:19 +0000
+
 astromenace (1.3.2+repack-6) unstable; urgency=medium
 
   * Standards-Version will not be bumped to 4.1.4 or newer, because
diff --git a/debian/compat b/debian/compat
deleted file mode 100644
index 48082f7..0000000
--- a/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-12
diff --git a/debian/control b/debian/control
index 448f78e..4c19ffe 100644
--- a/debian/control
+++ b/debian/control
@@ -5,7 +5,7 @@ Maintainer: Debian Games Team <pkg-games-devel@lists.alioth.debian.org>
 Uploaders: Boris Pek <tehnick@debian.org>
 Standards-Version: 4.1.3
 Build-Depends: cmake,
-               debhelper (>= 12~),
+               debhelper-compat (= 12),
                imagemagick,
                libalut-dev,
                libfontconfig1-dev,
diff --git a/debian/upstream/metadata b/debian/upstream/metadata
index 67003ed..44fa441 100644
--- a/debian/upstream/metadata
+++ b/debian/upstream/metadata
@@ -1,5 +1,3 @@
-Name: AstroMenace
-Contact: Michael Kurinnoy <viewizard@viewizard.com>
 Security-Contact: Michael Kurinnoy <viewizard@viewizard.com>
 Repository: https://github.com/viewizard/astromenace.git
 Repository-Browse: https://github.com/viewizard/astromenace

Run locally

Try this locally (using the lintian-brush package):

debcheckout astromenace
cd astromenace
lintian-brush

More details

Full run details