Lintian Fixes - brightd

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/brightd lintian-fixes/main

Summary

Diff

diff --git a/debian/changelog b/debian/changelog
index 705c936..e8b049b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+brightd (0.4.1-3) UNRELEASED; urgency=medium
+
+  * Use secure URI in debian/watch.
+  * Use secure URI in Homepage field.
+  * Bump debhelper from old 9 to 12.
+  * Set debhelper-compat version in Build-Depends.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Wed, 20 Nov 2019 10:58:44 +0000
+
 brightd (0.4.1-2) unstable; urgency=medium
 
   * Refresh the patch.
diff --git a/debian/compat b/debian/compat
deleted file mode 100644
index ec63514..0000000
--- a/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-9
diff --git a/debian/control b/debian/control
index 7785b44..d5e18fa 100644
--- a/debian/control
+++ b/debian/control
@@ -2,9 +2,9 @@ Source: brightd
 Section: utils
 Priority: optional
 Maintainer: Andrej Shadura <andrewsh@debian.org>
-Build-Depends: debhelper (>= 9), libx11-dev, x11proto-scrnsaver-dev, libxss-dev
+Build-Depends: debhelper-compat (= 12), libx11-dev, x11proto-scrnsaver-dev, libxss-dev
 Standards-Version: 3.9.5
-Homepage: http://pberndt.com/Programme/Linux/brightd/
+Homepage: https://pberndt.com/Programme/Linux/brightd/
 Vcs-Browser: https://browse.dgit.debian.org/brightd.git/
 Vcs-Git: https://git.dgit.debian.org/brightd
 
diff --git a/debian/watch b/debian/watch
index d318896..91a44a1 100644
--- a/debian/watch
+++ b/debian/watch
@@ -3,4 +3,4 @@ version=3
 
 # <Webpage URL> <string match>
 opts="downloadurlmangle=s/$/\?ct=raw&sub=att/,versionmangle=s/_/~/" \
-http://pberndt.com/Programme/Linux/brightd/_download .*/brightd-(.*)\.tar\.bz2
+https://pberndt.com/Programme/Linux/brightd/_download .*/brightd-(.*)\.tar\.bz2

Run locally

Try this locally (using the lintian-brush package):

debcheckout brightd
cd brightd
lintian-brush

More details

Full run details