Lintian Fixes - flare-engine

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/flare-engine lintian-fixes/main

Summary

Diff

diff --git a/debian/changelog b/debian/changelog
index fbb51146..769b1fcc 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,15 @@
+flare-engine (1.09.01-2) UNRELEASED; urgency=medium
+
+  * debian/copyright: use spaces rather than tabs to start continuation lines.
+  * Use secure URI in Homepage field.
+  * Bump debhelper from old 11 to 12.
+  * Set debhelper-compat version in Build-Depends.
+  * Set upstream metadata fields: Bug-Database, Bug-Submit, Repository,
+    Repository-Browse.
+  * Update standards version to 4.5.0, no changes needed.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Wed, 07 Apr 2021 15:18:16 -0000
+
 flare-engine (1.09.01-1) unstable; urgency=medium
 
   * New upstream release (Closes: #913944)
diff --git a/debian/compat b/debian/compat
deleted file mode 100644
index b4de3947..00000000
--- a/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-11
diff --git a/debian/control b/debian/control
index caab1ba5..f9990b07 100644
--- a/debian/control
+++ b/debian/control
@@ -3,14 +3,14 @@ Section: games
 Priority: optional
 Maintainer: Manuel A. Fernandez Montecelo <mafm@debian.org>
 Uploaders: Martin Quinson <mquinson@debian.org>
-Build-Depends: debhelper (>= 11~),
+Build-Depends: debhelper-compat (= 12),
                cmake (>= 2.6),
                libsdl2-dev,
                libsdl2-image-dev,
                libsdl2-mixer-dev,
                libsdl2-ttf-dev
-Standards-Version: 4.3.0
-Homepage: http://flarerpg.org/
+Standards-Version: 4.5.0
+Homepage: https://flarerpg.org/
 Vcs-Git: https://salsa.debian.org/games-team/flare-engine.git
 Vcs-Browser: https://salsa.debian.org/games-team/flare-engine
 
diff --git a/debian/copyright b/debian/copyright
index 71ff2543..eef17bf5 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -52,7 +52,7 @@ Comment:
 
 Files: debian/*
 Copyright: 2011-2012 Jan-Hendrik Peters <hennr@hennr.name>
-	   2011-2015 Manuel A. Fernandez Montecelo <manuel.montezelo@gmail.com>
+           2011-2015 Manuel A. Fernandez Montecelo <manuel.montezelo@gmail.com>
 License: GPL-3+
 
 
diff --git a/debian/upstream/metadata b/debian/upstream/metadata
new file mode 100644
index 00000000..25366ab9
--- /dev/null
+++ b/debian/upstream/metadata
@@ -0,0 +1,5 @@
+---
+Bug-Database: https://github.com/flareteam/flare-engine/issues
+Bug-Submit: https://github.com/flareteam/flare-engine/issues/new
+Repository: https://github.com/flareteam/flare-engine.git
+Repository-Browse: https://github.com/flareteam/flare-engine

Debdiff

[The following lists of changes regard files as different if they have different names, permissions or owners.]

Files in second set of .debs but not in first

-rw-r--r--  root/root   /usr/lib/debug/.build-id/7e/c19c348429c572885312bcde17449252613a85.debug

Files in first set of .debs but not in second

-rw-r--r--  root/root   /usr/lib/debug/.build-id/26/4f276752a86d96fb93116a45f6c897904a44fc.debug

Control files of package flare-engine: lines which differ (wdiff format)

  • Depends: libc6 (>= 2.27), libsdl2-2.0-0 (>= 2.0.12+dfsg1), 2.0.12), libsdl2-image-2.0-0 (>= 2.0.2), libsdl2-mixer-2.0-0 (>= 2.0.2), libsdl2-ttf-2.0-0 (>= 2.0.14), libstdc++6 (>= 9), fonts-liberation, ttf-unifont
  • Homepage: http://flarerpg.org/ https://flarerpg.org/

Control files of package flare-engine-dbgsym: lines which differ (wdiff format)

  • Build-Ids: 264f276752a86d96fb93116a45f6c897904a44fc 7ec19c348429c572885312bcde17449252613a85

Run locally

Try this locally (using the lintian-brush package):

debcheckout flare-engine
cd flare-engine
lintian-brush

More details

Full run details