Lintian Fixes - gimp-plugin-registry

Ready changes

Merge these changes:

Summary

Diff

diff --git a/debian/changelog b/debian/changelog
index 71e278e..6e7bb63 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -39,7 +39,8 @@ gimp-plugin-registry (7.20140602) unstable; urgency=medium
 
 gimp-plugin-registry (5.20140429) unstable; urgency=low
 
-  * [07aa8a09] Migrate to the packaging system taken from nagios-plugins-contrib.
+  * [07aa8a09] Migrate to the packaging system taken from
+    nagios-plugins-contrib.
   * [54be3d44] Fix plugin name generation.
   * [f71bba3f] Rework the whole packagaging scripts / magic.
     Also make package buildable again by adding
@@ -114,7 +115,8 @@ gimp-plugin-registry (3.5.4-1) unstable; urgency=low
   * [a2114978] Rename seperate+ source folder.
   * [81425b5c] Seperate+: Update to version 0.5.8
   * [2a0bb193] Contactsheet: Updating to version 2.15
-  * [fe2c8eb2] Elsamuko: Updating to latest version from https://sites.google.com/site/elsamuko/gimp
+  * [fe2c8eb2] Elsamuko: Updating to latest version from
+    https://sites.google.com/site/elsamuko/gimp
   * [cf79b0d7] Remove .gmo files which will be removed at build time anyway.
   * [a2eb33a9] Updating copyright and control files.
   * [19eefff0] Refreshing patches.
@@ -394,7 +396,7 @@ gimp-plugin-registry (1.0-1) unstable; urgency=low
   * debian/control:
     - Adding liblqr-1-0-dev to Build-Depends.
   * debian/TODO:
-    - dropping file, nothing left which should be includeded in the package. 
+    - dropping file, nothing left which should be includeded in the package.
 
  -- Bernd Zeimetz <bzed@debian.org>  Sat, 14 Jun 2008 18:18:29 +0200
 
@@ -463,7 +465,7 @@ gimp-plugin-registry (0.9-1) unstable; urgency=low
 
   * Removing the 'dustcleaner' plugin for now.
     It is imho not mature enough to be part of a stable release.
-  
+
  -- Bernd Zeimetz <bzed@debian.org>  Wed, 04 Jun 2008 17:05:42 +0200
 
 gimp-plugin-registry (0.5.1-4) unstable; urgency=low
@@ -479,7 +481,7 @@ gimp-plugin-registry (0.5.1-3) unstable; urgency=low
     - Using libglew-dev as build dependency instead of libglew1.4-dev
       (Closes: #465631).
     - Using gfortran based build dependencies for blas and lapack
-      (Closes: #463950). 
+      (Closes: #463950).
 
  -- Bernd Zeimetz <bzed@debian.org>  Wed, 13 Feb 2008 21:50:21 +0100
 
diff --git a/debian/control b/debian/control
index 7b0b5ab..6879fec 100644
--- a/debian/control
+++ b/debian/control
@@ -16,12 +16,12 @@ Architecture: any
 Depends: gimp (>= 2.6),
  ${shlibs:Depends}, ${misc:Depends},
  python, libtiff-tools, xdg-utils,
-Suggests: icc-profiles, 
+Suggests: icc-profiles,
 Breaks: gimp-refocus (<< 0.9.0-2), gimp-save-for-web, gimp-resynthesizer (<< 0.16-2~)
 Replaces: gimp-refocus (<< 0.9.0-2), gimp-save-for-web, gimp-resynthesizer
 Provides: gimp-save-for-web, gimp-resynthesizer
 Enhances: gimp
-Recommends: gimp-gmic, 
+Recommends: gimp-gmic,
 Description: repository of optional extensions for GIMP
  The package contains the following plugins:
  .
diff --git a/debian/rules b/debian/rules
index f34120b..23836ad 100755
--- a/debian/rules
+++ b/debian/rules
@@ -68,7 +68,7 @@ dh_auto_install-%:
 	   if [ -n "$$opts" ]; then \
 	   	dpkg-shlibdeps -O $$opts | grep shlibs:Depends > debian/$*/substvars ;\
 	   fi
-       
+
 dh_auto_%:
 	set -e; \
 	    export auto_command=`echo $* | sed 's,-.*,,;s,^,dh_auto_,'` ;\
@@ -86,7 +86,7 @@ override_dh_auto_install: $(PLUGINS:%=dh_auto_install-%)
 	#$(PACKAGING_HELPER) --generate-readme
 
 #override_dh_auto_test: $(PLUGINS:%=dh_auto_test-%)
-override_dh_auto_test: 
+override_dh_auto_test:
 	# nothign to do right now.
 
 override_dh_python2:
diff --git a/debian/source/format b/debian/source/format
index d3827e7..89ae9db 100644
--- a/debian/source/format
+++ b/debian/source/format
@@ -1 +1 @@
-1.0
+3.0 (native)

Failed fixers:

See the worker log for details.

Run locally

Try this locally (using the lintian-brush package):

debcheckout gimp-plugin-registry
cd gimp-plugin-registry
lintian-brush

More details

Full run details