Lintian Fixes - lowmem

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/lowmem lintian-fixes/main

Summary

Diff

diff --git a/debian/changelog b/debian/changelog
index 9561bd6..7e3acfd 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+lowmem (1.51) UNRELEASED; urgency=medium
+
+  * Move source package lintian overrides to debian/source.
+  * Bump debhelper from deprecated 9 to 12.
+  * Set debhelper-compat version in Build-Depends.
+  * Use ?= for assignments to architecture variables.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Wed, 23 Jun 2021 06:24:17 -0000
+
 lowmem (1.50) unstable; urgency=medium
 
   * Allow with e.g. lowmem=+0 to force a lowmem level, not only bump it.
diff --git a/debian/compat b/debian/compat
deleted file mode 100644
index ec63514..0000000
--- a/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-9
diff --git a/debian/control b/debian/control
index b8b8122..47e08f2 100644
--- a/debian/control
+++ b/debian/control
@@ -2,7 +2,7 @@ Source: lowmem
 Section: debian-installer
 Priority: optional
 Maintainer: Debian Install System Team <debian-boot@lists.debian.org>
-Build-Depends: debhelper (>= 9), dpkg-dev (>= 1.9.0)
+Build-Depends: debhelper-compat (= 12), dpkg-dev (>= 1.9.0)
 Vcs-Browser: https://salsa.debian.org/installer-team/lowmem
 Vcs-Git: https://salsa.debian.org/installer-team/lowmem.git
 
diff --git a/debian/rules b/debian/rules
index 7158eb0..602179b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,7 +1,7 @@
 #! /usr/bin/make -f
 
 DEB_BUILD_GNU_TYPE := $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-DEB_HOST_GNU_TYPE := $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 
 %:
 	dh $@
diff --git a/debian/source.lintian-overrides b/debian/source/lintian-overrides
similarity index 100%
rename from debian/source.lintian-overrides
rename to debian/source/lintian-overrides

Debdiff

File lists identical (after any substitutions)

No differences were encountered between the control files of package lowmem

No differences were encountered between the control files of package lowmemcheck

Run locally

Try this locally (using the lintian-brush package):

debcheckout lowmem
cd lowmem
DEB_UPDATE_CHANGELOG=auto lintian-brush

More details

Full run details