Lintian Fixes - lua-zlib

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/lua-zlib lintian-fixes/main

Summary

Diff

diff --git a/debian/changelog b/debian/changelog
index f33f1d4..8f61820 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,15 @@
+lua-zlib (1.2-2) UNRELEASED; urgency=medium
+
+  * Trim trailing whitespace.
+  * Use versioned copyright format URI.
+  * Use secure URI in Homepage field.
+  * Set debhelper-compat version in Build-Depends.
+  * Set upstream metadata fields: Bug-Database, Bug-Submit, Repository,
+    Repository-Browse.
+  * Update standards version to 4.4.1, no changes needed.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Fri, 28 Feb 2020 16:31:23 +0000
+
 lua-zlib (1.2-1) unstable; urgency=medium
 
   * New upstream release.
@@ -29,7 +41,7 @@ lua-zlib (0.2+git+1+9622739-2) unstable; urgency=medium
 
 lua-zlib (0.2+git+1+9622739-1) unstable; urgency=low
 
-  * add Privides: ${lua:Provides} to control 
+  * add Privides: ${lua:Provides} to control
   * new upstream snapshot integrating debian patches:
     - 0001-Fix-avail_in-value-for-lz.deflate.patch
     - 0002-Lua5.2-require-does-not-set-a-global.patch
@@ -38,12 +50,12 @@ lua-zlib (0.2+git+1+9622739-1) unstable; urgency=low
 
 lua-zlib (0.2+gitcfa1ecd-1) unstable; urgency=low
 
-  * New snapshot supporting lua5.2 
+  * New snapshot supporting lua5.2
   * Remove lua5.2 path, merged upstream
   * Package moved to git
   * Patch fixing upstream bug if no string is given to deflate
-  * Patch making the test file lua5.2 compatible 
-  * Fix copyright naming the license Expat and not MIT/X 
+  * Patch making the test file lua5.2 compatible
+  * Fix copyright naming the license Expat and not MIT/X
 
  -- Enrico Tassi <gareuselesinge@debian.org>  Sun, 08 Apr 2012 18:34:50 +0200
 
diff --git a/debian/compat b/debian/compat
deleted file mode 100644
index 48082f7..0000000
--- a/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-12
diff --git a/debian/control b/debian/control
index 5595087..93f1871 100644
--- a/debian/control
+++ b/debian/control
@@ -3,9 +3,9 @@ Section: interpreters
 Priority: optional
 Maintainer: Enrico Tassi <gareuselesinge@debian.org>
 Uploaders: Sergei Golovan <sgolovan@debian.org>
-Build-Depends: debhelper (>= 12), dh-lua, zlib1g-dev
-Standards-Version: 4.4.0
-Homepage: http://github.com/brimworks/lua-zlib
+Build-Depends: debhelper-compat (= 12), dh-lua, zlib1g-dev
+Standards-Version: 4.4.1
+Homepage: https://github.com/brimworks/lua-zlib
 Vcs-Git: https://salsa.debian.org/lua-team/lua-zlib.git
 Vcs-Browser: https://salsa.debian.org/lua-team/lua-zlib
 
diff --git a/debian/copyright b/debian/copyright
index caf8298..ee2061f 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -1,4 +1,4 @@
-Format: http://dep.debian.net/deps/dep5/ 
+Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
 Upstream-Name: lua-zlib
 Upstream-Contact: Brian Maher <maherb at brimworks dot com>
 Source: http://github.com/brimworks/lua-zlib
diff --git a/debian/upstream/metadata b/debian/upstream/metadata
new file mode 100644
index 0000000..3b770ce
--- /dev/null
+++ b/debian/upstream/metadata
@@ -0,0 +1,4 @@
+Bug-Database: https://github.com/brimworks/lua-zlib/issues
+Bug-Submit: https://github.com/brimworks/lua-zlib/issues/new
+Repository: https://github.com/brimworks/lua-zlib.git
+Repository-Browse: https://github.com/brimworks/lua-zlib

Run locally

Try this locally (using the lintian-brush package):

debcheckout lua-zlib
cd lua-zlib
lintian-brush

More details

Full run details