Lintian Fixes - lxqt-qtplugin

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/lxqt-qtplugin lintian-fixes/main

Summary

  • Trim trailing whitespace. (trailing-whitespace)
  • Fix field name typo in debian/upstream/metadata (Repository-Browser => Repository-Browse).
  • Set upstream metadata fields: Repository.
  • Remove obsolete field Name from debian/upstream/metadata (already present in machine-readable debian/copyright).
  • Update standards version to 4.5.0, no changes needed. (out-of-date-standards-version)
  • Avoid explicitly specifying -Wl,--as-needed linker flag. (debian-rules-uses-as-needed-linker-flag)

Diff

diff --git a/debian/changelog b/debian/changelog
index 102f64f..389a98a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,16 @@
+lxqt-qtplugin (0.16.0-2) UNRELEASED; urgency=medium
+
+  * Trim trailing whitespace.
+  * Fix field name typo in debian/upstream/metadata (Repository-Browser =>
+    Repository-Browse).
+  * Set upstream metadata fields: Repository.
+  * Remove obsolete field Name from debian/upstream/metadata (already present in
+    machine-readable debian/copyright).
+  * Update standards version to 4.5.0, no changes needed.
+  * Avoid explicitly specifying -Wl,--as-needed linker flag.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Wed, 21 Apr 2021 17:34:22 -0000
+
 lxqt-qtplugin (0.16.0-1) unstable; urgency=medium
 
   [ Alf Gaida ]
@@ -13,7 +26,7 @@ lxqt-qtplugin (0.16.0-1) unstable; urgency=medium
 lxqt-qtplugin (0.14.0-3) unstable; urgency=medium
 
   * Try to load the versioned libfm-qt.so.6 instead of libfm-qt.so
-    (Closes: #927905) 
+    (Closes: #927905)
 
  -- Alf Gaida <agaida@siduction.org>  Wed, 24 Apr 2019 23:05:04 +0200
 
diff --git a/debian/control b/debian/control
index 52cbacb..846b037 100644
--- a/debian/control
+++ b/debian/control
@@ -16,7 +16,7 @@ Build-Depends: debhelper-compat (= 12),
                libx11-dev,
                lxqt-build-tools (>= 0.8.0~),
                qtbase5-private-dev
-Standards-Version: 4.4.0
+Standards-Version: 4.5.0
 Vcs-Browser: https://salsa.debian.org/lxqt-team/lxqt-qtplugin
 Vcs-Git: https://salsa.debian.org/lxqt-team/lxqt-qtplugin.git
 Homepage: https://github.com/lxqt/lxqt-qtplugin
diff --git a/debian/rules b/debian/rules
index 3850f73..eb09d04 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,7 +2,6 @@
 # export DH_VERBOSE=1
 
 export LC_ALL=C.UTF-8
-export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
 export DEB_BUILD_MAINT_OPTIONS = hardening=+all
 
 %:
diff --git a/debian/upstream/metadata b/debian/upstream/metadata
index 8c57d99..9bc6c78 100644
--- a/debian/upstream/metadata
+++ b/debian/upstream/metadata
@@ -1,7 +1,6 @@
-Name: lxqt-qtplugin
 Bug-Database: https://github.com/lxqt/lxqt-qtplugin/issues
 Bug-Submit: https://github.com/lxqt/lxqt-qtplugin/issues/new
 Changelog: https://github.com/lxqt/lxqt-qtplugin/blob/master/CHANGELOG
-Repository: https://github.com/lxqt/lxqt-qtplugin
-Repository-Browser: https://github.com/lxqt/lxqt-qtplugin
+Repository: https://github.com/lxqt/lxqt-qtplugin.git
+Repository-Browse: https://github.com/lxqt/lxqt-qtplugin
 

Debdiff

File lists identical (after any substitutions)

No differences were encountered between the control files of package lxqt-qtplugin

No differences were encountered between the control files of package lxqt-qtplugin-dbgsym

Run locally

Try this locally (using the lintian-brush package):

debcheckout lxqt-qtplugin
cd lxqt-qtplugin
lintian-brush

More details

Full run details