Lintian Fixes - pip-requirements-el

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/pip-requirements-el lintian-fixes/main

Summary

Diff

=== modified file 'debian/changelog'
--- a/debian/changelog	2019-10-05 15:58:14 +0000
+++ b/debian/changelog	2020-07-19 11:28:31 +0000
@@ -1,7 +1,14 @@
 pip-requirements-el (0.5-3) UNRELEASED; urgency=medium
 
+  [ David Krauser ]
   * Update maintainer email address
 
+  [ Debian Janitor ]
+  * Bump debhelper from old 11 to 12.
+  * Set debhelper-compat version in Build-Depends.
+  * Set upstream metadata fields: Bug-Database, Bug-Submit, Repository,
+    Repository-Browse.
+
  -- David Krauser <david@krauser.org>  Fri, 04 Oct 2019 14:56:38 -0400
 
 pip-requirements-el (0.5-2) unstable; urgency=medium

=== removed file 'debian/compat'
--- a/debian/compat	2018-03-03 17:56:23 +0000
+++ b/debian/compat	1970-01-01 00:00:00 +0000
@@ -1,1 +0,0 @@
-11

=== modified file 'debian/control'
--- a/debian/control	2019-10-05 15:58:14 +0000
+++ b/debian/control	2020-07-19 11:27:46 +0000
@@ -3,8 +3,7 @@
 Priority: optional
 Maintainer: Debian Emacsen Team <debian-emacsen@lists.debian.org>
 Uploaders: Lev Lamberov <dogsleg@debian.org>
-Build-Depends: debhelper (>= 11),
-               dh-elpa
+Build-Depends: debhelper-compat (= 12), dh-elpa
 Standards-Version: 4.1.3
 Homepage: https://github.com/Wilfred/pip-requirements.el
 Vcs-Browser: https://salsa.debian.org/emacsen-team/pip-requirements-el

=== added directory 'debian/upstream'
=== added file 'debian/upstream/metadata'
--- a/debian/upstream/metadata	1970-01-01 00:00:00 +0000
+++ b/debian/upstream/metadata	2020-07-19 11:28:31 +0000
@@ -0,0 +1,5 @@
+---
+Bug-Database: https://github.com/Wilfred/pip-requirements.el/issues
+Bug-Submit: https://github.com/Wilfred/pip-requirements.el/issues/new
+Repository: https://github.com/Wilfred/pip-requirements.el.git
+Repository-Browse: https://github.com/Wilfred/pip-requirements.el

Debdiff

File lists identical (after any substitutions)

No differences were encountered in the control files

Run locally

Try this locally (using the lintian-brush package):

debcheckout pip-requirements-el
cd pip-requirements-el
lintian-brush

More details

Full run details