Lintian Fixes - plexus-archiver

Ready changes

Merge these changes:

Summary

Diff

diff --git a/debian/changelog b/debian/changelog
index 23489b3..7e7b5c6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+plexus-archiver (3.6.0-3) UNRELEASED; urgency=medium
+
+  * Bump debhelper from old 11 to 12.
+  * Set debhelper-compat version in Build-Depends.
+  * Update standards version to 4.2.1, no changes needed.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Tue, 02 Feb 2021 22:17:57 -0000
+
 plexus-archiver (3.6.0-2) unstable; urgency=medium
 
   * Team upload.
diff --git a/debian/compat b/debian/compat
deleted file mode 100644
index b4de394..0000000
--- a/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-11
diff --git a/debian/control b/debian/control
index d88c85f..57b8a04 100644
--- a/debian/control
+++ b/debian/control
@@ -6,7 +6,7 @@ Uploaders:
  Torsten Werner <twerner@debian.org>,
  Ludovic Claude <ludovic.claude@laposte.net>
 Build-Depends:
- debhelper (>= 11~),
+ debhelper-compat (= 12),
  default-jdk,
  junit4,
  libcommons-compress-java (>= 1.9),
@@ -17,7 +17,7 @@ Build-Depends:
  libsnappy-java,
  libxz-java,
  maven-debian-helper (>= 2.2)
-Standards-Version: 4.2.0
+Standards-Version: 4.2.1
 Vcs-Git: https://salsa.debian.org/java-team/plexus-archiver.git
 Vcs-Browser: https://salsa.debian.org/java-team/plexus-archiver
 Homepage: https://codehaus-plexus.github.io/plexus-archiver/

Run locally

Try this locally (using the lintian-brush package):

debcheckout plexus-archiver
cd plexus-archiver
lintian-brush --exclude=upstream-metadata-file

More details

Full run details