Lintian Fixes - policykit-1-gnome

Ready changes

Merge these changes:

Summary

Diff

diff --git a/debian/changelog b/debian/changelog
index 76cf6fc..9c68fc2 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+policykit-1-gnome (0.105-8) UNRELEASED; urgency=medium
+
+  * Trim trailing whitespace.
+  * Set upstream metadata fields: Bug-Submit (from ./configure),
+    Repository, Repository-Browse.
+  * Use canonical URL in Vcs-Git.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Wed, 25 Dec 2019 00:40:24 +0000
+
 policykit-1-gnome (0.105-7) unstable; urgency=medium
 
   * Update Vcs-* for migration to salsa
@@ -240,7 +249,7 @@ policykit-1-gnome (0.94-2) unstable; urgency=low
   * rename debian/patches/01-xfce-autostart.patch
     to debian/patches/01-fix-autostart.patch
   * debian/patches/01-fix-autostart.patch:
-    - comment the OnlyShowIn line out to make it autostart on 
+    - comment the OnlyShowIn line out to make it autostart on
       KDE as well (LP: #444661) (until KDE gets its own native
       agent)
 
@@ -299,7 +308,7 @@ policykit-gnome (0.9.2-2) unstable; urgency=low
 
 policykit-gnome (0.9.2-1) unstable; urgency=low
 
-  * New upstream release. 
+  * New upstream release.
   * debian/control
     - Bump Build-Depends on libgtk2.0-dev to (>= 2.13.6).
     - Drop Build-Depends on libsexy-dev.
@@ -328,7 +337,7 @@ policykit-gnome (0.9-2) unstable; urgency=low
 
 policykit-gnome (0.9-1) unstable; urgency=low
 
-  * New upstream release. 
+  * New upstream release.
   * debian/control
     - Bump Standards-Version to 3.8.0. No further changes.
   * debian/patches/03-fix_i18n.patch
@@ -341,7 +350,7 @@ policykit-gnome (0.8-2) unstable; urgency=low
   * debian/patches/03-fix_i18n.patch
     - Set the correct gettext domain to make the translations show up.
       Thanks to James Westby for the patch. (Closes: #482066)
-  * Add symbols file for libpolkit-gnome0. 
+  * Add symbols file for libpolkit-gnome0.
 
  -- Michael Biebl <biebl@debian.org>  Fri, 23 May 2008 05:23:30 +0200
 
@@ -410,4 +419,3 @@ policykit-gnome (0.5-1) experimental; urgency=low
   * Initial release. (Closes: #442254)
 
  -- Michael Biebl <biebl@debian.org>  Fri, 14 Sep 2007 14:24:03 +0200
-
diff --git a/debian/control b/debian/control
index 4ea0c92..be815fb 100644
--- a/debian/control
+++ b/debian/control
@@ -15,7 +15,7 @@ Build-Depends: debhelper (>= 10),
                pkg-config
 Standards-Version: 4.1.4
 X-Ubuntu-Use-Langpack: yes
-Vcs-Git: https://salsa.debian.org/utopia-team/polkit-gnome
+Vcs-Git: https://salsa.debian.org/utopia-team/polkit-gnome.git
 Vcs-Browser: https://salsa.debian.org/utopia-team/polkit-gnome
 Homepage: https://wiki.gnome.org/Projects/PolicyKit
 
diff --git a/debian/upstream/metadata b/debian/upstream/metadata
new file mode 100644
index 0000000..77e2830
--- /dev/null
+++ b/debian/upstream/metadata
@@ -0,0 +1,3 @@
+Bug-Submit: http://lists.freedesktop.org/mailman/listinfo/polkit-devel
+Repository: https://gitlab.gnome.org/GNOME/policykit-gnome.git
+Repository-Browse: https://gitlab.gnome.org/GNOME/policykit-gnome

Debdiff

[The following lists of changes regard files as different if they have different names, permissions or owners.]

Files in second set of .debs but not in first

-rw-r--r--  root/root   /usr/lib/debug/.build-id/46/9191c668fdea6a492df5f780fe3ae676acba20.debug

Files in first set of .debs but not in second

-rw-r--r--  root/root   /usr/lib/debug/.build-id/23/37b5cb09671b79193b5f334f5aef94cd205da0.debug

No differences were encountered between the control files of package policykit-1-gnome

Control files of package policykit-1-gnome-dbgsym: lines which differ (wdiff format)

  • Build-Ids: 2337b5cb09671b79193b5f334f5aef94cd205da0 469191c668fdea6a492df5f780fe3ae676acba20

Run locally

Try this locally (using the lintian-brush package):

debcheckout policykit-1-gnome
cd policykit-1-gnome
lintian-brush

More details

Full run details