Lintian Fixes - pseudo

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/pseudo lintian-fixes/main

Summary

Diff

diff --git a/debian/changelog b/debian/changelog
index 8912234..eab5b12 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,14 @@
 pseudo (1.8.1+git20161012-2) UNRELEASED; urgency=medium
 
+  [ Ondřej Nový ]
   * d/copyright: Use https protocol in Format field
   * d/control: Add Vcs-* field
 
+  [ Debian Janitor ]
+  * Add missing ${misc:Depends} to Depends for libpseudo.
+  * Bump debhelper from old 9 to 12.
+  * Set debhelper-compat version in Build-Depends.
+
  -- Ondřej Nový <onovy@debian.org>  Mon, 01 Oct 2018 09:57:45 +0200
 
 pseudo (1.8.1+git20161012-1) unstable; urgency=medium
diff --git a/debian/compat b/debian/compat
deleted file mode 100644
index ec63514..0000000
--- a/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-9
diff --git a/debian/control b/debian/control
index 3903cd8..98f745b 100644
--- a/debian/control
+++ b/debian/control
@@ -2,7 +2,7 @@ Source: pseudo
 Section: utils
 Priority: optional
 Maintainer: Andrew Shadura <andrewsh@debian.org>
-Build-Depends: debhelper (>=9), attr, libattr1-dev, python, libsqlite3-dev
+Build-Depends: debhelper-compat (= 12), attr, libattr1-dev, python, libsqlite3-dev
 Standards-Version: 3.9.6
 Homepage: https://www.yoctoproject.org/tools-resources/projects/pseudo
 Vcs-Browser: https://salsa.debian.org/debian/pseudo
@@ -29,7 +29,7 @@ Architecture: any
 Multi-Arch: same
 Replaces: pseudo (<< 1.7.5-3~)
 Breaks: pseudo (<< 1.7.5-3~)
-Depends: ${shlibs:Depends}
+Depends: ${shlibs:Depends}, ${misc:Depends}
 Description: advanced tool for simulating superuser privileges
  The pseudo utility offers a way to run commands in a virtualized "root"
  environment, allowing ordinary users to run commands which give the

Run locally

Try this locally (using the lintian-brush package):

debcheckout pseudo
cd pseudo
lintian-brush

More details

Full run details