Lintian Fixes - xfce4-diskperf-plugin

Ready changes

Merge these changes:

Summary

Diff

diff --git a/debian/changelog b/debian/changelog
index 539bc2a..81d0234 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,8 @@ xfce4-diskperf-plugin (2.6.2-2) UNRELEASED; urgency=low
 
   * Apply multi-arch hints.
     + xfce4-diskperf-plugin: Add Multi-Arch: same.
+  * Trim trailing whitespace.
+  * Update standards version to 4.5.0, no changes needed.
 
  -- Debian Janitor <janitor@jelmer.uk>  Fri, 04 Sep 2020 19:58:43 -0000
 
@@ -39,9 +41,9 @@ xfce4-diskperf-plugin (2.6.1-1) unstable; urgency=medium
   * run wrap-and-sort.
   * debian/control:
     - update standards version to 4.1.1.
-    - replace xfce4-panel-dev build-dep by libxfce4panel-2.0-dev 
-    - replace libxfce4ui-1-dev build-dep by libxfce4ui-2-dev 
-    - drop libxml2 and libxml-parser-dev build-deps. 
+    - replace xfce4-panel-dev build-dep by libxfce4panel-2.0-dev
+    - replace libxfce4ui-1-dev build-dep by libxfce4ui-2-dev
+    - drop libxml2 and libxml-parser-dev build-deps.
   * debian/copyright:
     - remove obsolete download URL.
 
@@ -139,9 +141,9 @@ xfce4-diskperf-plugin (2.3.0-2) unstable; urgency=low
   * Upload to unstable.
   * debian/control:
     - remove Emanuele, Simon, Rudy and Martin from uploaders, thanks to them.
-    - bump Xfce build-deps to 4.8. 
-    - update standards version to 3.9.2. 
-    - remove cdbs build-dep. 
+    - bump Xfce build-deps to 4.8.
+    - update standards version to 3.9.2.
+    - remove cdbs build-dep.
 
  -- Yves-Alexis Perez <corsac@debian.org>  Tue, 19 Apr 2011 22:57:04 +0200
 
@@ -192,7 +194,7 @@ xfce4-diskperf-plugin (2.2.0-2) unstable; urgency=low
     - debhelper build-dep bumped to 7.
     - drop versionning on xfce4-panel build-dep.
     - bump standards version to 3.8.3.
-    - add depends on ${misc:Depends}. 
+    - add depends on ${misc:Depends}.
 
  -- Yves-Alexis Perez <corsac@debian.org>  Sat, 09 Jan 2010 15:37:52 +0100
 
@@ -233,7 +235,7 @@ xfce4-diskperf-plugin (2.0-2) unstable; urgency=low
  -- Yves-Alexis Perez <corsac@corsac.net>  Wed, 26 Jul 2006 17:49:14 +0100
 
 xfce4-diskperf-plugin (2.0-1) unstable; urgency=low
-  
+
   * (Jani Monoses)
     * Set Standard policy version to 3.6.2
   * (Yves-Alexis Perez)
@@ -252,7 +254,7 @@ xfce4-diskperf-plugin (1.5-3) unstable; urgency=high
 
 xfce4-diskperf-plugin (1.5-2) unstable; urgency=low
 
-  * Rebuilding to fix libxfcegui dependency 
+  * Rebuilding to fix libxfcegui dependency
 
  -- Emanuele Rocca <ema@debian.org>  Mon, 20 Jun 2005 20:52:54 +0200
 
diff --git a/debian/control b/debian/control
index 51069fa..d97f4b2 100644
--- a/debian/control
+++ b/debian/control
@@ -10,7 +10,7 @@ Build-Depends: automake,
                libxfce4panel-2.0-dev (>= 4.12),
                libxfce4ui-2-dev,
                xfce4-dev-tools
-Standards-Version: 4.4.0
+Standards-Version: 4.5.0
 Homepage: https://goodies.xfce.org/
 Vcs-Git: https://salsa.debian.org/xfce-team/goodies/xfce4-diskperf-plugin.git
 Vcs-Browser: https://salsa.debian.org/xfce-team/goodies/xfce4-diskperf-plugin

Debdiff

[The following lists of changes regard files as different if they have different names, permissions or owners.]

Files in second set of .debs but not in first

-rw-r--r--  root/root   /usr/lib/debug/.build-id/7a/9ae75d8a476c73150f390e8dcdab410fa5298d.debug

Files in first set of .debs but not in second

-rw-r--r--  root/root   /usr/lib/debug/.build-id/b3/cbae23e22b748a20e0e713074658cb92541557.debug

No differences were encountered between the control files of package xfce4-diskperf-plugin

Control files of package xfce4-diskperf-plugin-dbgsym: lines which differ (wdiff format)

  • Build-Ids: b3cbae23e22b748a20e0e713074658cb92541557 7a9ae75d8a476c73150f390e8dcdab410fa5298d

Run locally

Try this locally (using the lintian-brush package):

debcheckout xfce4-diskperf-plugin
cd xfce4-diskperf-plugin
lintian-brush

More details

Full run details