scrub-obsolete Package - apache-pom

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/apache-pom scrub-obsolete/main

Diff

diff --git a/debian/changelog b/debian/changelog
index 1932d3b..bc69e4e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+apache-pom (18-2) UNRELEASED; urgency=medium
+
+  * Remove constraints unnecessary since stretch:
+    + Build-Depends: Drop versioned constraint on debhelper, maven-repo-helper.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Tue, 10 Nov 2020 12:30:53 -0000
+
 apache-pom (18-1) unstable; urgency=low
 
   * Team upload.
diff --git a/debian/control b/debian/control
index 04aadb4..1db26d8 100644
--- a/debian/control
+++ b/debian/control
@@ -4,7 +4,7 @@ Priority: optional
 Maintainer: Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>
 Uploaders: Ludovic Claude <ludovic.claude@laposte.net>,
            Damien Raude-Morvan <drazzib@debian.org>
-Build-Depends: debhelper (>= 10), default-jdk, maven-repo-helper (>= 1.7)
+Build-Depends: debhelper, default-jdk, maven-repo-helper
 Standards-Version: 4.0.0
 Vcs-Git: https://anonscm.debian.org/git/pkg-java/apache-pom.git
 Vcs-Browser: https://anonscm.debian.org/cgit/pkg-java/apache-pom.git

Run locally

Try this locally (using the lintian-brush package):

debcheckout apache-pom
cd apache-pom
deb-scrub-obsolete

More details

Full run details