scrub-obsolete Package - apper

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/apper scrub-obsolete/main

Diff

diff --git a/debian/control b/debian/control
index 0969b4b..c4f7dab 100644
--- a/debian/control
+++ b/debian/control
@@ -2,10 +2,10 @@ Source: apper
 Section: kde
 Priority: optional
 Maintainer: Matthias Klumpp <mak@debian.org>
-Build-Depends: cmake (>= 3.0),
+Build-Depends: cmake,
                debhelper-compat (= 12),
-               docbook (>= 4.5),
-               extra-cmake-modules (>= 5.14),
+               docbook,
+               extra-cmake-modules,
                kded5-dev,
                libappstreamqt-dev (>= 0.11.8),
                libdebconf-kde-dev (>= 1.0.2),
@@ -14,7 +14,7 @@ Build-Depends: cmake (>= 3.0),
                libkf5doctools-dev (>= 5.42),
                libkf5guiaddons-dev (>= 5.42),
                libkf5i18n-dev (>= 5.42),
-               libkf5kcmutils-dev(>= 5.42),
+               libkf5kcmutils-dev (>= 5.42),
                libkf5kio-dev (>= 5.42),
                libkf5notifications-dev (>= 5.42),
                libkf5textwidgets-dev (>= 5.42),
@@ -32,7 +32,7 @@ Vcs-Browser: https://salsa.debian.org/pkgutopia-team/apper
 Package: apper
 Architecture: any
 Depends: apper-data (>= ${source:Version}),
-         packagekit (>= 0.8.6),
+         packagekit,
          polkit-kde-agent-1 | policykit-1-gnome,
          software-properties-kde,
          ${misc:Depends},
@@ -55,8 +55,6 @@ Description: KDE package management tool using PackageKit
 
 Package: apper-data
 Architecture: all
-Replaces: apper (<< 0.7.2)
-Breaks: apper (<< 0.7.2)
 Depends: ${misc:Depends}
 Description: KDE package management tool using PackageKit (data files)
  PackageKit allows performing simple software management tasks over a DBus

Run locally

Try this locally (using the lintian-brush package):

debcheckout apper
cd apper
deb-scrub-obsolete

More details

Full run details