scrub-obsolete Package - base-installer

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/base-installer scrub-obsolete/main

Diff

diff --git a/debian/control b/debian/control
index 6648c41d..cf0fa2c4 100644
--- a/debian/control
+++ b/debian/control
@@ -3,14 +3,14 @@ Section: debian-installer
 Priority: required
 Maintainer: Debian Install System Team <debian-boot@lists.debian.org>
 Uploaders: Petter Reinholdtsen <pere@debian.org>, Colin Watson <cjwatson@debian.org>, dann frazier <dannf@debian.org>, Steve Langasek <vorlon@debian.org>, Steve McIntyre <93sam@debian.org>
-Build-Depends: debhelper (>= 9), libdebconfclient0-dev (>= 0.46), libdebian-installer4-dev (>= 0.41)
+Build-Depends: debhelper, libdebconfclient0-dev (>= 0.46), libdebian-installer4-dev (>= 0.41)
 Vcs-Browser: https://salsa.debian.org/installer-team/base-installer
 Vcs-Git: https://salsa.debian.org/installer-team/base-installer.git
 
 Package: base-installer
 Package-Type: udeb
 Architecture: all
-Depends: ${shlibs:Depends}, ${misc:Depends}, di-utils-mapdevfs, di-utils (>= 1.48), rootskel (>= 1.19)
+Depends: ${shlibs:Depends}, ${misc:Depends}, di-utils-mapdevfs, di-utils (>= 1.48), rootskel
 Description: base system installation framework
 
 Package: bootstrap-base

Run locally

Try this locally (using the lintian-brush package):

debcheckout base-installer
cd base-installer
DEB_UPDATE_CHANGELOG=auto deb-scrub-obsolete

More details

Full run details