scrub-obsolete Package - dolphin

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/dolphin scrub-obsolete/main

Diff

diff --git a/debian/changelog b/debian/changelog
index 8a2f627..32a21c5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,6 +4,10 @@ dolphin (4:20.08.2-2) UNRELEASED; urgency=medium
   * Drop l10n migration rules, not required anymore after 2 stable releases.
   * Update project homepage URL.
 
+  [ Debian Janitor ]
+  * Remove constraints unnecessary since stretch:
+    + Build-Depends: Drop versioned constraint on cmake, pkg-kde-tools.
+
  -- Aurélien COUDERC <coucouf@debian.org>  Mon, 26 Oct 2020 22:09:45 +0100
 
 dolphin (4:20.08.2-1) unstable; urgency=medium
diff --git a/debian/control b/debian/control
index 122c045..52a295f 100644
--- a/debian/control
+++ b/debian/control
@@ -4,7 +4,7 @@ Priority: optional
 Maintainer: Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
 Uploaders: Maximiliano Curia <maxy@debian.org>
 Build-Depends: baloo-kf5-dev (>= 5.71.0~) [!hurd-any],
-               cmake (>= 3.0~),
+               cmake,
                debhelper-compat (= 13),
                extra-cmake-modules (>= 5.71.0~),
                gettext,
@@ -33,7 +33,7 @@ Build-Depends: baloo-kf5-dev (>= 5.71.0~) [!hurd-any],
                libphonon4qt5experimental-dev,
                libpackagekitqt5-dev,
                pkg-config,
-               pkg-kde-tools (>= 0.12),
+               pkg-kde-tools,
                qtbase5-dev (>= 5.11.0~),
 Standards-Version: 4.5.0
 Rules-Requires-Root: no

Run locally

Try this locally (using the lintian-brush package):

debcheckout dolphin
cd dolphin
deb-scrub-obsolete

More details

Full run details