scrub-obsolete Package - fcgiwrap

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/fcgiwrap scrub-obsolete/main

Diff

diff --git a/debian/changelog b/debian/changelog
index ff35bee..febffbd 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+fcgiwrap (1.1.0-13) UNRELEASED; urgency=medium
+
+  * Remove constraints unnecessary since stretch:
+    + Build-Depends: Drop versioned constraint on autoconf and debhelper.
+    + fcgiwrap: Drop versioned constraint on spawn-fcgi in Depends.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Fri, 09 Jul 2021 14:09:26 -0000
+
 fcgiwrap (1.1.0-12) unstable; urgency=medium
 
   * Add fcgiwrap to test dependencies
diff --git a/debian/control b/debian/control
index 1ef88d7..012b982 100644
--- a/debian/control
+++ b/debian/control
@@ -3,8 +3,8 @@ Section: web
 Priority: optional
 Maintainer: Debian fcgiwrap Maintainers <team+fcgiwrap@tracker.debian.org>
 Uploaders: Jordi Mallach <jordi@debian.org>, Peter Colberg <peter@colberg.org>
-Build-Depends: autoconf (>= 2.61),
-               debhelper (>= 11~),
+Build-Depends: autoconf,
+               debhelper,
                libfcgi-dev,
                libsystemd-dev [linux-any],
                pkg-config
@@ -16,7 +16,7 @@ Homepage: https://github.com/gnosek/fcgiwrap
 Package: fcgiwrap
 Architecture: any
 Depends: lsb-base (>= 3.0-6),
-         spawn-fcgi (>= 1.6.1) | systemd,
+         spawn-fcgi | systemd,
          ${misc:Depends},
          ${shlibs:Depends}
 Enhances: nginx

Run locally

Try this locally (using the lintian-brush package):

debcheckout fcgiwrap
cd fcgiwrap
DEB_UPDATE_CHANGELOG=auto deb-scrub-obsolete

More details

Full run details