scrub-obsolete Package - hunspell-kk

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/hunspell-kk scrub-obsolete/main

Diff

diff --git a/debian/changelog b/debian/changelog
index 25156f4..ffd4c13 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+hunspell-kk (1.1-3) UNRELEASED; urgency=medium
+
+  * Remove constraints unnecessary since stretch:
+    + Build-Depends: Drop versioned constraint on debhelper.
+    + hunspell-kk: Drop versioned constraint on dictionaries-common in Depends.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Fri, 27 Nov 2020 23:11:39 -0000
+
 hunspell-kk (1.1-2) unstable; urgency=low
 
   * debian/control:
diff --git a/debian/control b/debian/control
index daf11c9..7b13bd3 100644
--- a/debian/control
+++ b/debian/control
@@ -2,7 +2,7 @@ Source: hunspell-kk
 Section: text
 Priority: optional
 Maintainer: Timur Birsh <taem@linukz.org>
-Build-Depends: debhelper (>= 9)
+Build-Depends: debhelper
 Build-Depends-Indep: dictionaries-common-dev (>= 1.12.11)
 Standards-Version: 3.9.4
 Homepage: http://extensions.services.openoffice.org/en/project/dict-kk
@@ -11,7 +11,7 @@ Vcs-Browser: http://github.com/taem/hunspell-kk/tree/master
 
 Package: hunspell-kk
 Architecture: all
-Depends: dictionaries-common (>= 1.12.11), ${misc:Depends}
+Depends: dictionaries-common, ${misc:Depends}
 Provides: hunspell-dictionary, hunspell-dictionary-kk, myspell-dictionary, myspell-dictionary-kk
 Suggests: iceape-browser | iceweasel | icedove, openoffice.org (>= 1.0.3-3)
 Conflicts: openoffice.org (<= 1.0.3-2)

Run locally

Try this locally (using the lintian-brush package):

debcheckout hunspell-kk
cd hunspell-kk
deb-scrub-obsolete

More details

Full run details