scrub-obsolete Package - japi-compliance-checker

Ready changes

Merge these changes:

Diff

diff --git a/debian/changelog b/debian/changelog
index 2aa5514..d243d46 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+japi-compliance-checker (2.4-3) UNRELEASED; urgency=medium
+
+  * Remove constraints unnecessary since stretch:
+    + Build-Depends: Drop versioned constraint on debhelper.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Tue, 15 Jun 2021 19:05:30 -0000
+
 japi-compliance-checker (2.4-2) unstable; urgency=medium
 
   * Update Vcs- fields from Alioth -> salsa.debian.org
diff --git a/debian/control b/debian/control
index 5bad227..7760794 100644
--- a/debian/control
+++ b/debian/control
@@ -1,7 +1,7 @@
 Source: japi-compliance-checker
 Section: devel
 Priority: optional
-Build-Depends: debhelper (>= 11), help2man
+Build-Depends: debhelper, help2man
 Maintainer: Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>
 Uploaders: Emmanuel Bourg <ebourg@apache.org>,
  tony mancill <tmancill@debian.org>

Run locally

Try this locally (using the lintian-brush package):

debcheckout japi-compliance-checker
cd japi-compliance-checker
DEB_UPDATE_CHANGELOG=auto scrub-obsolete

More details

Full run details