scrub-obsolete Package - jxplorer

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/jxplorer scrub-obsolete/main

Diff

diff --git a/debian/changelog b/debian/changelog
index 7eb92d0..dc30944 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+jxplorer (3.3.2+dfsg-7) UNRELEASED; urgency=medium
+
+  * Remove constraints unnecessary since stretch:
+    + Build-Depends: Drop versioned constraint on debhelper.
+    + jxplorer: Drop versioned constraint on java-wrappers in Depends.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Wed, 19 May 2021 23:02:01 -0000
+
 jxplorer (3.3.2+dfsg-6) unstable; urgency=medium
 
   * Update Vcs fields for migration from Alioth -> Salsa
diff --git a/debian/control b/debian/control
index 60331b3..b25b41d 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Section: admin
 Priority: optional
 Maintainer: Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>
 Uploaders: tony mancill <tmancill@debian.org>
-Build-Depends: debhelper (>= 11)
+Build-Depends: debhelper
 Build-Depends-Indep: default-jdk, javahelper (>= 0.24), javahelp2, junit,
  imagemagick
 Standards-Version: 4.3.0
@@ -14,7 +14,7 @@ Homepage: http://jxplorer.org/
 Package: jxplorer
 Architecture: all
 Depends: default-jre | java6-runtime, javahelp2, ${misc:Depends},
- java-wrappers (>= 0.1.14), ca-certificates-java
+ java-wrappers, ca-certificates-java
 Description: Java LDAP Browser
  JXplorer is an open source LDAP browser originally developed by
  Computer Associates' eTrust Directory development lab. It is a

Run locally

Try this locally (using the lintian-brush package):

debcheckout jxplorer
cd jxplorer
deb-scrub-obsolete

More details

Full run details