scrub-obsolete Package - jzmq

Ready changes

Diff

diff --git a/debian/changelog b/debian/changelog
index b785fb8..9f0b2d4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+jzmq (3.1.0-16) UNRELEASED; urgency=medium
+
+  * Remove constraints unnecessary since buster:
+    + Build-Depends: Drop versioned constraint on debhelper,
+      default-jdk-headless and dh-exec.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Thu, 09 Sep 2021 08:30:34 -0000
+
 jzmq (3.1.0-15) unstable; urgency=medium
 
   * Set source and target version to 1.7 (Closes: Bug#981991)
diff --git a/debian/control b/debian/control
index ac9bfe2..06a79a4 100644
--- a/debian/control
+++ b/debian/control
@@ -2,7 +2,7 @@ Source: jzmq
 Section: java
 Priority: optional
 Maintainer: Jan Niehusmann <jan@debian.org>
-Build-Depends: debhelper (>= 9), dh-exec (>=0.3), libzmq5-dev, default-jdk-headless (>= 2:1.8) | openjdk-8-jdk-headless | java-8-sdk-headless, libpgm-dev, pkg-config, libtool, autoconf, libtool-bin, automake, maven-repo-helper, javahelper, dh-autoreconf, default-jdk-doc, junit4
+Build-Depends: debhelper, dh-exec, libzmq5-dev, default-jdk-headless | openjdk-8-jdk-headless | java-8-sdk-headless, libpgm-dev, pkg-config, libtool, autoconf, libtool-bin, automake, maven-repo-helper, javahelper, dh-autoreconf, default-jdk-doc, junit4
 Standards-Version: 3.9.6
 Homepage: https://github.com/zeromq/jzmq
 Vcs-Git: https://salsa.debian.org/jan/jzmq.git
@@ -49,4 +49,3 @@ Description: Documentation for ZeroMQ Java bindings (jzmq)
  multiple transport protocols and more.
  .
  This package contains JavaDoc documentation for the Java bindings for ZeroMQ.
-

Run locally

Try this locally (using the package):

debcheckout jzmq
cd jzmq
DEB_UPDATE_CHANGELOG=auto deb-scrub-obsolete

More details

Full run details