scrub-obsolete Package - kblackbox

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/kblackbox scrub-obsolete/main

Diff

diff --git a/debian/changelog b/debian/changelog
index b89dce9..3624aae 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+kblackbox (4:20.04.3-2) UNRELEASED; urgency=medium
+
+  * Remove constraints unnecessary since stretch:
+    + Build-Depends: Drop versioned constraint on cmake, pkg-kde-tools.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Sat, 14 Nov 2020 16:33:09 -0000
+
 kblackbox (4:20.04.3-1) unstable; urgency=medium
 
   * Team upload.
diff --git a/debian/control b/debian/control
index eee8929..15efd93 100644
--- a/debian/control
+++ b/debian/control
@@ -8,7 +8,7 @@ Uploaders: Daniel Schepler <schepler@debian.org>,
            George Kiagiadakis <gkiagiad@csd.uoc.gr>,
            Eshat Cakar <info@eshat.de>,
            Maximiliano Curia <maxy@debian.org>,
-Build-Depends: cmake (>= 3.5~),
+Build-Depends: cmake,
                debhelper-compat (= 12),
                extra-cmake-modules (>= 5.30.0~),
                gettext,
@@ -23,7 +23,7 @@ Build-Depends: cmake (>= 3.5~),
                libkf5textwidgets-dev (>= 5.30.0~),
                libkf5xmlgui-dev (>= 5.30.0~),
                libqt5svg5-dev (>= 5.7.0~),
-               pkg-kde-tools (>> 0.15.15),
+               pkg-kde-tools,
                qtbase5-dev (>= 5.7.0~),
 Standards-Version: 4.5.0
 Rules-Requires-Root: no

Run locally

Try this locally (using the lintian-brush package):

debcheckout kblackbox
cd kblackbox
deb-scrub-obsolete

More details

Full run details