scrub-obsolete Package - kcalcore

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/kcalcore scrub-obsolete/main

Diff

diff --git a/debian/changelog b/debian/changelog
index e7fc348..102743b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+kcalcore (5:5.74.0-3) UNRELEASED; urgency=medium
+
+  * Remove constraints unnecessary since stretch:
+    + Build-Depends: Drop versioned constraint on cmake, pkg-kde-tools.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Mon, 09 Nov 2020 20:19:05 -0000
+
 kcalcore (5:5.74.0-2) unstable; urgency=medium
 
   * Team upload to unstable.
diff --git a/debian/control b/debian/control
index fc269f6..65fb8bb 100644
--- a/debian/control
+++ b/debian/control
@@ -4,12 +4,12 @@ Priority: optional
 Maintainer: Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
 Uploaders: Maximiliano Curia <maxy@debian.org>, Sandro Knauß <hefee@debian.org>
 Build-Depends: bison,
-               cmake (>= 3.5~),
+               cmake,
                debhelper-compat (= 13),
                doxygen,
                extra-cmake-modules (>= 5.74.0~),
                libical-dev (>= 2.0~),
-               pkg-kde-tools (>> 0.15.15),
+               pkg-kde-tools,
                qhelpgenerator-qt5,
                qtbase5-dev (>= 5.12.0~),
                qttools5-dev,

Run locally

Try this locally (using the lintian-brush package):

debcheckout kcalcore
cd kcalcore
deb-scrub-obsolete

More details

Full run details