scrub-obsolete Package - kconfig

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/kconfig scrub-obsolete/main

Diff

diff --git a/debian/changelog b/debian/changelog
index cabe958..3f4808c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+kconfig (5.78.0-5) UNRELEASED; urgency=medium
+
+  * Remove constraints unnecessary since stretch:
+    + Build-Depends: Drop versioned constraint on cmake, doxygen and
+      pkg-kde-tools.
+    + libkf5configgui5: Drop versioned constraint on frameworkintegration in
+      Breaks.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Thu, 22 Apr 2021 12:30:27 -0000
+
 kconfig (5.78.0-4) unstable; urgency=medium
 
   * Reduce build deps (Closes: #981202)
diff --git a/debian/control b/debian/control
index bcd63d4..9c68cb0 100644
--- a/debian/control
+++ b/debian/control
@@ -4,18 +4,18 @@ Priority: optional
 Maintainer: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
 Uploaders: Maximiliano Curia <maxy@debian.org>,
            Norbert Preining <norbert@preining.info>
-Build-Depends: cmake (>= 3.5~),
+Build-Depends: cmake,
                dbus-x11 <!nocheck>,
                debhelper-compat (= 13),
-               doxygen (>= 1.8.13~),
+               doxygen,
                extra-cmake-modules (>= 5.78.0~),
                libqt5sql5-sqlite,
-               pkg-kde-tools (>= 0.15.15ubuntu1~),
+               pkg-kde-tools,
                qtbase5-dev (>= 5.14.0~),
                qttools5-dev (>= 5.4),
                qttools5-dev-tools (>= 5.4),
                xauth <!nocheck>,
-               xvfb <!nocheck>,
+               xvfb <!nocheck>
 Standards-Version: 4.5.1
 Homepage: https://invent.kde.org/frameworks/kconfig
 Vcs-Browser: https://salsa.debian.org/qt-kde-team/kde/kconfig
@@ -266,8 +266,7 @@ Multi-Arch: same
 Depends: libkf5config-data (= ${source:Version}),
          ${misc:Depends},
          ${shlibs:Depends}
-Breaks: frameworkintegration (<< 5.28),
-        kdesignerplugin (<< 5.42),
+Breaks: kdesignerplugin (<< 5.42),
         kio (<< 5.42),
         kross (<< 5.42),
         ktexteditor-katepart (<< 5.42),

Run locally

Try this locally (using the lintian-brush package):

debcheckout kconfig
cd kconfig
deb-scrub-obsolete

More details

Full run details