scrub-obsolete Package - kdevelop-php

Ready changes

Diff

diff --git a/debian/changelog b/debian/changelog
index fbe47dd..ba436a7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -9,6 +9,13 @@ kdevelop-php (5.6.2-2) UNRELEASED; urgency=medium
   * CI: disable the blhc job.
   * Use the ${misc:Pre-Depends} substvar in kdevelop-php.
 
+  [ Debian Janitor ]
+  * Remove constraints unnecessary since buster:
+    + Build-Depends: Drop versioned constraint on cmake, kdevelop-pg-qt,
+      libkf5archive-dev, libkf5i18n-dev, libkf5itemmodels-dev,
+      libkf5kcmutils-dev, libkf5texteditor-dev, libkf5threadweaver-dev,
+      pkg-kde-tools and qtbase5-dev.
+
  -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Sun, 19 Sep 2021 10:45:11 +0200
 
 kdevelop-php (5.6.2-1) unstable; urgency=medium
diff --git a/debian/control b/debian/control
index 8afa419..827071f 100644
--- a/debian/control
+++ b/debian/control
@@ -4,20 +4,20 @@ Priority: optional
 Maintainer: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
 Uploaders: Modestas Vainius <modax@debian.org>,
            Andreas Cord-Landwehr <cola@uni-paderborn.de>,
-Build-Depends: cmake (>= 3.0),
+Build-Depends: cmake,
                debhelper-compat (= 13),
                extra-cmake-modules (>= 5.59~),
                gettext,
-               qtbase5-dev (>= 5.7.0),
-               libkf5archive-dev (>= 5.28.0),
-               libkf5i18n-dev (>= 5.28.0),
-               libkf5itemmodels-dev (>= 5.28.0),
-               libkf5kcmutils-dev (>= 5.28.0),
-               libkf5texteditor-dev (>= 5.28.0),
-               libkf5threadweaver-dev (>= 5.28.0),
+               qtbase5-dev,
+               libkf5archive-dev,
+               libkf5i18n-dev,
+               libkf5itemmodels-dev,
+               libkf5kcmutils-dev,
+               libkf5texteditor-dev,
+               libkf5threadweaver-dev,
                kdevelop-dev (>= 4:5.6.2),
-               kdevelop-pg-qt (>= 2.0),
-               pkg-kde-tools (>= 0.15.16),
+               kdevelop-pg-qt,
+               pkg-kde-tools,
 Standards-Version: 4.6.0
 Rules-Requires-Root: no
 Homepage: https://www.kdevelop.org/

Run locally

Try this locally (using the package):

debcheckout kdevelop-php
cd kdevelop-php
DEB_UPDATE_CHANGELOG=auto deb-scrub-obsolete

More details

Full run details