scrub-obsolete Package - kdevelop-python

Ready changes

Diff

diff --git a/debian/changelog b/debian/changelog
index 4904d7c..36e5f8c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -9,6 +9,13 @@ kdevelop-python (5.6.2-2) UNRELEASED; urgency=medium
   * CI: disable the blhc job.
   * Use the ${misc:Pre-Depends} substvar in kdevelop-python-data.
 
+  [ Debian Janitor ]
+  * Remove constraints unnecessary since buster:
+    + Build-Depends: Drop versioned constraint on cmake, libkf5i18n-dev,
+      libkf5itemmodels-dev, libkf5kcmutils-dev, libkf5newstuff-dev,
+      libkf5texteditor-dev, libkf5threadweaver-dev, pkg-kde-tools and
+      qtbase5-dev.
+
  -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Sun, 19 Sep 2021 10:27:48 +0200
 
 kdevelop-python (5.6.2-1) unstable; urgency=medium
diff --git a/debian/control b/debian/control
index fe4d2c1..090c0fc 100644
--- a/debian/control
+++ b/debian/control
@@ -4,19 +4,19 @@ Priority: optional
 Maintainer: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
 Uploaders: Pino Toscano <pino@debian.org>,
            Andreas Cord-Landwehr <cola@uni-paderborn.de>
-Build-Depends: cmake (>= 3.0),
+Build-Depends: cmake,
                debhelper-compat (= 13),
                extra-cmake-modules (>= 5.59~),
                gettext,
-               qtbase5-dev (>= 5.7.0),
-               libkf5i18n-dev (>= 5.28.0),
-               libkf5itemmodels-dev (>= 5.28.0),
-               libkf5kcmutils-dev (>= 5.28.0),
-               libkf5newstuff-dev (>= 5.28.0),
-               libkf5texteditor-dev (>= 5.28.0),
-               libkf5threadweaver-dev (>= 5.28.0),
+               qtbase5-dev,
+               libkf5i18n-dev,
+               libkf5itemmodels-dev,
+               libkf5kcmutils-dev,
+               libkf5newstuff-dev,
+               libkf5texteditor-dev,
+               libkf5threadweaver-dev,
                kdevelop-dev (>= 4:5.6.2),
-               pkg-kde-tools (>= 0.15.16),
+               pkg-kde-tools,
                python3.9-dev,
 Standards-Version: 4.6.0
 Rules-Requires-Root: no

Run locally

Try this locally (using the package):

debcheckout kdevelop-python
cd kdevelop-python
DEB_UPDATE_CHANGELOG=auto deb-scrub-obsolete

More details

Full run details