scrub-obsolete Package - kglobalaccel

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/kglobalaccel scrub-obsolete/main

Diff

diff --git a/debian/changelog b/debian/changelog
index 109f80b..d7198eb 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,18 @@
+kglobalaccel (5.74.0-3) UNRELEASED; urgency=medium
+
+  * Remove constraints unnecessary since stretch:
+    + Build-Depends: Drop versioned constraint on cmake, pkg-kde-tools.
+    + libkf5globalaccel-bin: Drop versioned constraint on plasma-workspace in
+      Replaces.
+    + libkf5globalaccel-bin: Drop versioned constraint on plasma-workspace in
+      Breaks.
+    + libkf5globalaccel-data: Drop versioned constraint on plasma-workspace in
+      Replaces.
+    + libkf5globalaccel-data: Drop versioned constraint on plasma-workspace in
+      Breaks.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Thu, 12 Nov 2020 12:15:53 -0000
+
 kglobalaccel (5.74.0-2) unstable; urgency=medium
 
   * Team upload to unstable.
diff --git a/debian/control b/debian/control
index 7fe17e0..37211c3 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Section: libs
 Priority: optional
 Maintainer: Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
 Uploaders: Maximiliano Curia <maxy@debian.org>
-Build-Depends: cmake (>= 3.5~),
+Build-Depends: cmake,
                debhelper-compat (= 13),
                doxygen,
                extra-cmake-modules (>= 5.74.0~),
@@ -21,7 +21,7 @@ Build-Depends: cmake (>= 3.5~),
                libxcb-xtest0-dev,
                libxcb1-dev,
                pkg-config,
-               pkg-kde-tools (>= 0.15.15ubuntu1~),
+               pkg-kde-tools,
                qtbase5-dev (>= 5.12.0~),
                qttools5-dev,
                qttools5-dev-tools,
@@ -40,9 +40,8 @@ Breaks: libkf5kdelibs4support5 (<< 5.54),
         libkf5khtml5 (<< 5.54),
         libkf5plasma5 (<< 5.54),
         libkf5xmlgui5 (<< 5.54),
-        plasma-workspace (<= 4:5.2.0-1),
+        ,
         qml-module-org-kde-kquickcontrols (<< 5.54),
-Replaces: plasma-workspace (<= 4:5.2.0-1)
 Description: Configurable global shortcut support.
  KGlobalAccel allows you to have global accelerators that are
  independent of the focused window. Unlike regular shortcuts,
@@ -55,8 +54,8 @@ Package: libkf5globalaccel-data
 Architecture: all
 Multi-Arch: foreign
 Depends: ${misc:Depends}, ${shlibs:Depends}
-Breaks: libkf5globalaccel5-data, plasma-workspace (<< 4:5.2.0-0ubuntu2~)
-Replaces: libkf5globalaccel5-data, plasma-workspace (<< 4:5.2.0-0ubuntu2~)
+Breaks: libkf5globalaccel5-data, 
+Replaces: libkf5globalaccel5-data, 
 Description: Configurable global shortcut support.
  KGlobalAccel allows you to have global accelerators that are
  independent of the focused window. Unlike regular shortcuts,

Run locally

Try this locally (using the lintian-brush package):

debcheckout kglobalaccel
cd kglobalaccel
deb-scrub-obsolete

More details

Full run details