scrub-obsolete Package - kitemmodels

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/kitemmodels scrub-obsolete/main

Diff

diff --git a/debian/changelog b/debian/changelog
index d96d8be..b90b9e9 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,6 +4,10 @@ kitemmodels (5.74.0-3) UNRELEASED; urgency=medium
   * Disable fixfilepath feature, as it triggers build failures when
     enabled (Closes: #972737).
 
+  [ Debian Janitor ]
+  * Remove constraints unnecessary since stretch:
+    + Build-Depends: Drop versioned constraint on cmake, pkg-kde-tools.
+
  -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Mon, 26 Oct 2020 22:47:25 +0100
 
 kitemmodels (5.74.0-2) unstable; urgency=medium
diff --git a/debian/control b/debian/control
index e7e3027..dd92267 100644
--- a/debian/control
+++ b/debian/control
@@ -3,13 +3,13 @@ Section: libs
 Priority: optional
 Maintainer: Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
 Uploaders: Maximiliano Curia <maxy@debian.org>
-Build-Depends: cmake (>= 3.5~),
+Build-Depends: cmake,
                debhelper-compat (= 13),
                doxygen,
                extra-cmake-modules (>= 5.74.0~),
                graphviz,
                libqt5sql5-sqlite:native,
-               pkg-kde-tools (>= 0.15.15ubuntu1~),
+               pkg-kde-tools,
                qml-module-qtquick-controls <!nocheck>,
                qtbase5-dev (>= 5.12.0~),
                qtdeclarative5-dev (>= 5.12.0~),

Run locally

Try this locally (using the lintian-brush package):

debcheckout kitemmodels
cd kitemmodels
deb-scrub-obsolete

More details

Full run details