scrub-obsolete Package - kpeople

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/kpeople scrub-obsolete/main

Diff

diff --git a/debian/changelog b/debian/changelog
index d5d6045..4925c6c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,10 @@ kpeople (5.78.0-3) UNRELEASED; urgency=medium
   [ Norbert Preining ]
   * Remove graphviz from build depends.
 
+  [ Debian Janitor ]
+  * Remove constraints unnecessary since stretch:
+    + Build-Depends: Drop versioned constraint on cmake and pkg-kde-tools.
+
  -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Sat, 23 Jan 2021 10:28:20 +0900
 
 kpeople (5.78.0-2) unstable; urgency=medium
diff --git a/debian/control b/debian/control
index 879e606..cad30bd 100644
--- a/debian/control
+++ b/debian/control
@@ -4,7 +4,7 @@ Priority: optional
 Maintainer: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
 Uploaders: Maximiliano Curia <maxy@debian.org>,
            Norbert Preining <norbert@preining.info>
-Build-Depends: cmake (>= 3.5~),
+Build-Depends: cmake,
                dbus-x11,
                debhelper-compat (= 13),
                doxygen,
@@ -14,7 +14,7 @@ Build-Depends: cmake (>= 3.5~),
                libkf5itemviews-dev (>= 5.78.0~),
                libkf5widgetsaddons-dev (>= 5.78.0~),
                libqt5sql5-sqlite,
-               pkg-kde-tools (>> 0.15.15),
+               pkg-kde-tools,
                qtbase5-dev (>= 5.14.0~),
                qtdeclarative5-dev (>= 5.14.0~),
                qttools5-dev,

Run locally

Try this locally (using the lintian-brush package):

debcheckout kpeople
cd kpeople
deb-scrub-obsolete

More details

Full run details