scrub-obsolete Package - libksysguard

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/libksysguard scrub-obsolete/main

Diff

diff --git a/debian/changelog b/debian/changelog
index 1dcd09e..1747bc7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+libksysguard (4:5.20.5-2) UNRELEASED; urgency=medium
+
+  * Remove constraints unnecessary since stretch:
+    + Build-Depends: Drop versioned constraint on cmake and pkg-kde-tools.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Wed, 07 Apr 2021 04:32:18 -0000
+
 libksysguard (4:5.20.5-1) unstable; urgency=medium
 
   * New upstream release (5.20.5).
diff --git a/debian/control b/debian/control
index 9c89884..0a50c7b 100644
--- a/debian/control
+++ b/debian/control
@@ -5,7 +5,7 @@ Maintainer: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
 Uploaders: Scarlett Moore <sgmoore@kde.org>,
            Patrick Franz <patfra71@gmail.com>,
            Norbert Preining <norbert@preining.info>,
-Build-Depends: cmake (>= 3.0~),
+Build-Depends: cmake,
                debhelper-compat (= 13),
                extra-cmake-modules (>= 5.74.0~),
                gettext,
@@ -29,14 +29,14 @@ Build-Depends: cmake (>= 3.0~),
                libqt5x11extras5-dev (>= 5.15.0~),
                libx11-dev,
                libxres-dev,
-               pkg-kde-tools (>= 0.15.18~),
+               pkg-kde-tools,
                qtbase5-dev (>= 5.15.0~),
                qtscript5-dev (>= 5.15.0~),
                qttools5-dev (>= 5.15.0~),
                qtwebengine5-dev (>= 5.15.0~) [amd64 arm64 armhf i386 mipsel],
                xauth,
                xvfb,
-               zlib1g-dev,
+               zlib1g-dev
 Standards-Version: 4.5.0
 Homepage: https://invent.kde.org/plasma/libksysguard
 Vcs-Browser: https://salsa.debian.org/qt-kde-team/kde/libksysguard

Run locally

Try this locally (using the lintian-brush package):

debcheckout libksysguard
cd libksysguard
deb-scrub-obsolete

More details

Full run details