scrub-obsolete Package - netcat-openbsd

Ready changes

Merge these changes:

git pull https://janitor.debian.net/git/netcat-openbsd scrub-obsolete/main

Diff

diff --git a/debian/changelog b/debian/changelog
index e2bfda6..458d73c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+netcat-openbsd (1.217-3) UNRELEASED; urgency=medium
+
+  * Remove constraints unnecessary since stretch:
+    + netcat-openbsd: Drop versioned constraint on netcat in Replaces.
+    + netcat-openbsd: Drop versioned constraint on netcat in Breaks.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Sat, 07 Nov 2020 11:02:15 -0000
+
 netcat-openbsd (1.217-2) unstable; urgency=low
 
   * d/patches: Make getnameinfo(3) errors non-fatal in report_sock():
diff --git a/debian/control b/debian/control
index ffe3d4c..f06761f 100644
--- a/debian/control
+++ b/debian/control
@@ -13,8 +13,6 @@ Package: netcat-openbsd
 Architecture: any
 Depends: ${misc:Depends}, ${shlibs:Depends}
 Provides: netcat
-Breaks: netcat (<< 1.10-35)
-Replaces: netcat (<< 1.10-35)
 Description: TCP/IP swiss army knife
  A simple Unix utility which reads and writes data across network
  connections using TCP or UDP protocol.  It is designed to be a reliable

Run locally

Try this locally (using the lintian-brush package):

debcheckout netcat-openbsd
cd netcat-openbsd
deb-scrub-obsolete

More details

Full run details